summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD36
-rw-r--r--baresip-flags.patch45
-rw-r--r--patch-alsa.diff33
-rw-r--r--patch-v4l2.diff11
5 files changed, 68 insertions, 76 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aec19e569204..35718f8353a7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = baresip
pkgdesc = portable and modular SIP User-Agent with audio and video support
- pkgver = 0.4.20
+ pkgver = 0.6.2
pkgrel = 1
url = http://creytiv.com/baresip.html
arch = i686
@@ -15,19 +15,17 @@ pkgbase = baresip
makedepends = gst-plugins-good
makedepends = gst-plugins-ugly
makedepends = gtk2
- makedepends = libsrtp
makedepends = libsndfile
makedepends = libvpx
makedepends = libx11
makedepends = mpg123
makedepends = opus
- makedepends = sdl
makedepends = sdl2
makedepends = spandsp
- makedepends = speex
makedepends = speexdsp
makedepends = v4l-utils
depends = rem
+ depends = openssl
optdepends = alsa-lib: (alsa module)
optdepends = cairo: (cairo, rst modules)
optdepends = ffmpeg: (avcodec, avformat, h265 modules)
@@ -37,24 +35,19 @@ pkgbase = baresip
optdepends = gst-plugins-good: (gst1, gst_video1 modules)
optdepends = gst-plugins-ugly: (gst1, gst_video1 modules)
optdepends = gtk2: (gtk module)
- optdepends = libsrtp: (libsrtp module)
optdepends = libsndfile: (sndfile module)
optdepends = libvpx: (vpx module)
optdepends = libx11: (x11, x11grab modules)
optdepends = mpg123: (rst module)
optdepends = opus: (opus module)
- optdepends = sdl: (sdl module)
optdepends = sdl2: (sdl2 module)
optdepends = spandsp: (g722, g726,plc modules)
- optdepends = speex: (speex module)
optdepends = speexdsp: (speex_aec, speex_pp modules)
optdepends = v4l-utils: (v4l2 module)
- source = http://creytiv.com/pub/baresip-0.4.20.tar.gz
- source = patch-alsa.diff
- source = patch-v4l2.diff
- md5sums = b18f6560a7c4bc32ad56de1088989abf
- md5sums = d6be41540262d1525548901d8374d972
- md5sums = 218c383c58167f353ae228673291d0f2
+ source = http://creytiv.com/pub/baresip-0.6.2.tar.gz
+ source = baresip-flags.patch
+ sha256sums = e1fae11ea9e6dc861bb2c43d6bef641778945aad86581d58bc4b0ea64b8d28e2
+ sha256sums = 55af521d77e105bb519f60464b2e50b83da15eb8549c18dabefa15215b22fa92
pkgname = baresip
diff --git a/PKGBUILD b/PKGBUILD
index 4d9f4f2208dd..2ce270e417ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,15 @@
-# Maintainer: Dmitrij D. Czarkoff <czarkoff@gmail.com>
+# Maintainer: Andrew Sun <adsun701@gmail.com>
+# Contributor: Dmitrij D. Czarkoff <czarkoff@gmail.com>
+
pkgname=baresip
-pkgver=0.4.20
+pkgver=0.6.2
pkgrel=1
pkgdesc="portable and modular SIP User-Agent with audio and video support"
arch=('i686' 'x86_64')
url="http://creytiv.com/baresip.html"
license=('BSD')
-depends=('rem')
+depends=('rem'
+ 'openssl')
optdepends=('alsa-lib: (alsa module)'
'cairo: (cairo, rst modules)'
'ffmpeg: (avcodec, avformat, h265 modules)'
@@ -16,39 +19,34 @@ optdepends=('alsa-lib: (alsa module)'
'gst-plugins-good: (gst1, gst_video1 modules)'
'gst-plugins-ugly: (gst1, gst_video1 modules)'
'gtk2: (gtk module)'
- 'libsrtp: (libsrtp module)'
'libsndfile: (sndfile module)'
'libvpx: (vpx module)'
'libx11: (x11, x11grab modules)'
'mpg123: (rst module)'
'opus: (opus module)'
- 'sdl: (sdl module)'
'sdl2: (sdl2 module)'
'spandsp: (g722, g726,plc modules)'
- 'speex: (speex module)'
'speexdsp: (speex_aec, speex_pp modules)'
'v4l-utils: (v4l2 module)')
makedepends=(${optdepends[@]/%:*/})
source=("http://creytiv.com/pub/$pkgname-$pkgver.tar.gz"
- "patch-alsa.diff"
- "patch-v4l2.diff")
-md5sums=('b18f6560a7c4bc32ad56de1088989abf'
- 'd6be41540262d1525548901d8374d972'
- '218c383c58167f353ae228673291d0f2')
+ "baresip-flags.patch")
+sha256sums=('e1fae11ea9e6dc861bb2c43d6bef641778945aad86581d58bc4b0ea64b8d28e2'
+ '55af521d77e105bb519f60464b2e50b83da15eb8549c18dabefa15215b22fa92')
prepare() {
- cd "$pkgname-$pkgver"
- patch -p1 < ${srcdir}/patch-alsa.diff
- patch -p1 < ${srcdir}/patch-v4l2.diff
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -Np1 -i ${srcdir}/baresip-flags.patch
}
build() {
- cd "$pkgname-$pkgver"
- make V=1 USE_GST= USE_GST_VIDEO= PREFIX="/usr"
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make V=1 USE_GST= USE_GST_VIDEO= PREFIX="/usr"
}
package() {
- cd "$pkgname-$pkgver"
- make USE_GST= USE_GST_VIDEO= PREFIX="/usr" \
- DESTDIR="$pkgdir/" install
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make USE_GST= USE_GST_VIDEO= PREFIX="/usr" \
+ DESTDIR="$pkgdir/" install
+ install -Dm644 docs/COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
}
diff --git a/baresip-flags.patch b/baresip-flags.patch
new file mode 100644
index 000000000000..d19f5a0da970
--- /dev/null
+++ b/baresip-flags.patch
@@ -0,0 +1,45 @@
+diff -Naur baresip-0.6.2.orig/Makefile baresip-0.6.2/Makefile
+--- baresip-0.6.2.orig/Makefile 2019-05-06 19:50:16.033903247 -0400
++++ baresip-0.6.2/Makefile 2019-05-06 19:51:38.941047245 -0400
+@@ -170,7 +170,7 @@
+
+ $(SHARED): $(LIB_OBJS)
+ @echo " LD $@"
+- $(HIDE)$(LD) $(LFLAGS) $(SH_LFLAGS) $^ -L$(LIBRE_SO) -lre $(LIBS) -o $@
++ $(HIDE)$(LD) $(LDFLAGS) $(LFLAGS) $(SH_LFLAGS) $^ -L$(LIBRE_SO) -lre $(LIBS) -o $@
+
+ $(STATICLIB): $(LIB_OBJS)
+ @echo " AR $@"
+@@ -197,9 +197,9 @@
+ $(BIN): $(APP_OBJS)
+ @echo " LD $@"
+ ifneq ($(GPROF),)
+- $(HIDE)$(LD) $(LFLAGS) $(APP_LFLAGS) $^ ../re/libre.a $(LIBS) -o $@
++ $(HIDE)$(LD) $(LDFLAGS) $(LFLAGS) $(APP_LFLAGS) $^ ../re/libre.a $(LIBS) -o $@
+ else
+- $(HIDE)$(LD) $(LFLAGS) $(APP_LFLAGS) $^ \
++ $(HIDE)$(LD) $(LDFLAGS) $(LFLAGS) $(APP_LFLAGS) $^ \
+ -L$(LIBRE_SO) -lre $(LIBS) -o $@
+ endif
+
+@@ -210,7 +210,7 @@
+
+ $(TEST_BIN): $(STATICLIB) $(TEST_OBJS)
+ @echo " LD $@"
+- $(HIDE)$(CXX) $(LFLAGS) $(TEST_OBJS) \
++ $(HIDE)$(CXX) $(LDFLAGS) $(LFLAGS) $(TEST_OBJS) \
+ -L$(LIBRE_SO) -L. \
+ -l$(PROJECT) -lre $(LIBS) $(TEST_LIBS) -o $@
+
+diff -Naur baresip-0.6.2.orig/mk/mod.mk baresip-0.6.2/mk/mod.mk
+--- baresip-0.6.2.orig/mk/mod.mk 2019-05-06 19:50:16.037236599 -0400
++++ baresip-0.6.2/mk/mod.mk 2019-05-06 20:04:34.508833761 -0400
+@@ -33,7 +33,7 @@
+
+ $(MOD)$(MOD_SUFFIX): $($(MOD)_OBJS)
+ @echo " LD [M] $@"
+- $(HIDE)$(LD) $(LFLAGS) $(SH_LFLAGS) $(MOD_LFLAGS) \
++ $(HIDE)$(LD) $(LDFLAGS) $(LFLAGS) $(SH_LFLAGS) $(MOD_LFLAGS) \
+ $($(basename $@)_OBJS) \
+ $($(basename $@)_LFLAGS) -L$(LIBRE_SO) -lre -o $@
+
diff --git a/patch-alsa.diff b/patch-alsa.diff
deleted file mode 100644
index 92a6abc6356f..000000000000
--- a/patch-alsa.diff
+++ /dev/null
@@ -1,33 +0,0 @@
-diff -aur baresip-0.4.20.orig/modules/alsa/alsa.c baresip-0.4.20/modules/alsa/alsa.c
---- baresip-0.4.20.orig/modules/alsa/alsa.c 2016-12-03 12:40:57.032560190 +0100
-+++ baresip-0.4.20/modules/alsa/alsa.c 2016-12-03 12:41:12.644877089 +0100
-@@ -3,6 +3,7 @@
- *
- * Copyright (C) 2010 Creytiv.com
- */
-+#define _DEFAULT_SOURCE 1
- #define _POSIX_SOURCE 1
- #include <sys/types.h>
- #include <sys/time.h>
-diff -aur baresip-0.4.20.orig/modules/alsa/alsa_play.c baresip-0.4.20/modules/alsa/alsa_play.c
---- baresip-0.4.20.orig/modules/alsa/alsa_play.c 2016-12-03 12:40:57.032560190 +0100
-+++ baresip-0.4.20/modules/alsa/alsa_play.c 2016-12-03 12:41:12.644877089 +0100
-@@ -3,6 +3,7 @@
- *
- * Copyright (C) 2010 Creytiv.com
- */
-+#define _DEFAULT_SOURCE 1
- #define _POSIX_SOURCE 1
- #include <sys/types.h>
- #include <sys/time.h>
-diff -aur baresip-0.4.20.orig/modules/alsa/alsa_src.c baresip-0.4.20/modules/alsa/alsa_src.c
---- baresip-0.4.20.orig/modules/alsa/alsa_src.c 2016-12-03 12:40:57.032560190 +0100
-+++ baresip-0.4.20/modules/alsa/alsa_src.c 2016-12-03 12:41:12.644877089 +0100
-@@ -3,6 +3,7 @@
- *
- * Copyright (C) 2010 Creytiv.com
- */
-+#define _DEFAULT_SOURCE 1
- #define _POSIX_SOURCE 1
- #include <sys/types.h>
- #include <sys/time.h>
diff --git a/patch-v4l2.diff b/patch-v4l2.diff
deleted file mode 100644
index a7c2478b25b6..000000000000
--- a/patch-v4l2.diff
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -aur baresip-0.4.20.orig/modules/v4l2_codec/v4l2_codec.c baresip-0.4.20/modules/v4l2_codec/v4l2_codec.c
---- baresip-0.4.20.orig/modules/v4l2_codec/v4l2_codec.c 2016-12-03 12:43:50.201286104 +0100
-+++ baresip-0.4.20/modules/v4l2_codec/v4l2_codec.c 2016-12-03 12:44:30.328673626 +0100
-@@ -3,6 +3,7 @@
- *
- * Copyright (C) 2010 - 2015 Creytiv.com
- */
-+#define _DEFAULT_SOURCE 1
- #include <unistd.h>
- #include <stdlib.h>
- #include <string.h>