summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD25
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b112f7748104
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Mon Dec 19 18:28:07 UTC 2016
+pkgbase = barpyrus-git
+ pkgdesc = A python wrapper for lemonbar/conky
+ pkgver = r71.42fb779
+ pkgrel = 1
+ url = https://github.com/t-wissmann/barpyrus
+ arch = any
+ license = BSD
+ depends = python
+ depends = python-setuptools
+ depends = lemonbar
+ depends = siji-git
+ depends = herbstluftwm
+ optdepends = conky: To use the conky widget
+ source = git+https://github.com/t-wissmann/barpyrus.git
+ sha1sums = SKIP
+
+pkgname = barpyrus-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..47d038b523d6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Florian Bruhin (The Compiler) <archlinux.org@the-compiler.org>
+
+pkgname=barpyrus-git
+pkgver=r71.42fb779
+pkgrel=1
+pkgdesc="A python wrapper for lemonbar/conky"
+arch=(any)
+url="https://github.com/t-wissmann/barpyrus"
+license=('BSD')
+depends=('python' 'python-setuptools' 'lemonbar' 'siji-git' 'herbstluftwm')
+optdepends=('conky: To use the conky widget')
+source=("git+https://github.com/t-wissmann/barpyrus.git")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd barpyrus
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd barpyrus
+ python setup.py install --root="${pkgdir}" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: