summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--0001-Handle-removal-of-cmake-macro-qt5_use_modules.patch58
-rw-r--r--CHANGELOG.rst6
-rw-r--r--PKGBUILD18
4 files changed, 82 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cc8d68ddafff..d2736c18785a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = barrier
pkgdesc = Open-source KVM software based on Synergy
pkgver = 2.1.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/debauchee/barrier
changelog = CHANGELOG.rst
arch = x86_64
@@ -22,7 +22,9 @@ pkgbase = barrier
depends = qt5-base
depends = hicolor-icon-theme
source = https://github.com/debauchee/barrier/archive/v2.1.1.tar.gz
+ source = 0001-Handle-removal-of-cmake-macro-qt5_use_modules.patch
sha256sums = 775d504db6091c4dc479657fc4fc566ceb9893426664ae60c9a2bb198b562774
+ sha256sums = 142750baea34ee068ee77a7557fd4fd69ede0e151dcf8d905d88c67c59a22cc5
pkgname = barrier
diff --git a/0001-Handle-removal-of-cmake-macro-qt5_use_modules.patch b/0001-Handle-removal-of-cmake-macro-qt5_use_modules.patch
new file mode 100644
index 000000000000..e0b51a2de6a7
--- /dev/null
+++ b/0001-Handle-removal-of-cmake-macro-qt5_use_modules.patch
@@ -0,0 +1,58 @@
+From 090abd2bfad2caf788317f0da11de753d06a276f Mon Sep 17 00:00:00 2001
+From: Tilman Blumenbach <tilman+git@ax86.net>
+Date: Tue, 29 May 2018 23:25:33 +0200
+Subject: [PATCH] Handle removal of cmake macro qt5_use_modules.
+
+That macro was deprecated for some time already and it looks like it has
+finally been removed.
+
+See also:
+
+ - Issue: https://github.com/debauchee/barrier/issues/49
+ - Patch source: https://gitweb.gentoo.org/repo/gentoo.git/plain/x11-misc/synergy/files/synergy-1.9.1-qt-5.11.patch?id=5dd1f7a3908dec9ae6cf6773acd8ec3b33fc0b2c
+---
+ src/gui/CMakeLists.txt | 2 +-
+ src/gui/src/ActionDialog.cpp | 1 +
+ src/gui/src/ScreenSetupView.cpp | 1 +
+ 3 files changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/src/gui/CMakeLists.txt b/src/gui/CMakeLists.txt
+index 9c902867..12fb5fda 100644
+--- a/src/gui/CMakeLists.txt
++++ b/src/gui/CMakeLists.txt
+@@ -22,7 +22,7 @@ add_executable (barrier WIN32
+
+ include_directories (./src)
+
+-qt5_use_modules (barrier Core Widgets Network)
++target_link_libraries (barrier Qt5::Core Qt5::Widgets Qt5::Network)
+ target_compile_definitions (barrier PRIVATE -DBARRIER_VERSION_STAGE="${BARRIER_VERSION_STAGE}")
+ target_compile_definitions (barrier PRIVATE -DBARRIER_REVISION="${BARRIER_REVISION}")
+
+diff --git a/src/gui/src/ActionDialog.cpp b/src/gui/src/ActionDialog.cpp
+index e824ea3c..3565cfbc 100644
+--- a/src/gui/src/ActionDialog.cpp
++++ b/src/gui/src/ActionDialog.cpp
+@@ -25,6 +25,7 @@
+
+ #include <QtCore>
+ #include <QtGui>
++#include <QButtonGroup>
+
+ ActionDialog::ActionDialog(QWidget* parent, ServerConfig& config, Hotkey& hotkey, Action& action) :
+ QDialog(parent, Qt::WindowTitleHint | Qt::WindowSystemMenuHint),
+diff --git a/src/gui/src/ScreenSetupView.cpp b/src/gui/src/ScreenSetupView.cpp
+index e42ae17e..46e70990 100644
+--- a/src/gui/src/ScreenSetupView.cpp
++++ b/src/gui/src/ScreenSetupView.cpp
+@@ -22,6 +22,7 @@
+
+ #include <QtCore>
+ #include <QtGui>
++#include <QHeaderView>
+
+ ScreenSetupView::ScreenSetupView(QWidget* parent) :
+ QTableView(parent)
+--
+2.17.0
+
diff --git a/CHANGELOG.rst b/CHANGELOG.rst
index d03e8864f136..1fa4e260aa0b 100644
--- a/CHANGELOG.rst
+++ b/CHANGELOG.rst
@@ -1,6 +1,11 @@
Changelog for package ``barrier``
=================================
+2.1.1-2 - 2018-05-30
+--------------------
+
+- Work around Barrier `issue 49`_.
+
2.1.1-1 - 2018-05-20
--------------------
@@ -11,3 +16,4 @@ Changelog for package ``barrier``
.. _2.1.1: https://github.com/debauchee/barrier/releases/tag/v2.1.1
+.. _issue 49: https://github.com/debauchee/barrier/issues/49
diff --git a/PKGBUILD b/PKGBUILD
index 6b3ae6681d57..015060652fde 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,28 @@
pkgname=barrier
pkgver=2.1.1
-pkgrel=1
+pkgrel=2
pkgdesc="Open-source KVM software based on Synergy"
url="https://github.com/debauchee/barrier"
license=("custom:GPL2WithOpenSSLException")
changelog=CHANGELOG.rst
-source=("https://github.com/debauchee/barrier/archive/v${pkgver?}.tar.gz")
+source=(
+ "https://github.com/debauchee/barrier/archive/v${pkgver?}.tar.gz"
+ 0001-Handle-removal-of-cmake-macro-qt5_use_modules.patch
+)
arch=(x86_64)
depends=(curl libx11 libxrandr libxext libxinerama xorgproto libxtst libxi avahi libsm libice openssl qt5-base
hicolor-icon-theme)
makedepends=(cmake)
+prepare() {
+ cd "barrier-${pkgver?}"
+
+ for patch in "${srcdir?}"/*.patch; do
+ patch -Np1 -i "${patch?}"
+ done
+}
+
build() {
cd "barrier-${pkgver?}"
@@ -46,4 +57,5 @@ package() {
install -m 644 doc/barrier.conf* "${pkgdir?}/usr/share/doc/${pkgname?}"
}
-sha256sums=('775d504db6091c4dc479657fc4fc566ceb9893426664ae60c9a2bb198b562774')
+sha256sums=('775d504db6091c4dc479657fc4fc566ceb9893426664ae60c9a2bb198b562774'
+ '142750baea34ee068ee77a7557fd4fd69ede0e151dcf8d905d88c67c59a22cc5')