summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--CHANGELOG.rst26
-rw-r--r--PKGBUILD48
3 files changed, 79 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 551164e712e0..caa3df95f223 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,16 @@
pkgbase = barrier
pkgdesc = Open-source KVM software based on Synergy
pkgver = 2.1.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/debauchee/barrier
changelog = CHANGELOG.rst
arch = x86_64
license = custom:GPL2WithOpenSSLException
makedepends = cmake
+ makedepends = qt5-base
+ makedepends = hicolor-icon-theme
depends = curl
+ depends = avahi
depends = libx11
depends = libxrandr
depends = libxext
@@ -15,14 +18,18 @@ pkgbase = barrier
depends = xorgproto
depends = libxtst
depends = libxi
- depends = avahi
depends = libsm
depends = libice
depends = openssl
- depends = qt5-base
- depends = hicolor-icon-theme
source = https://github.com/debauchee/barrier/archive/v2.1.2.tar.gz
sha384sums = 9d3f1e784ca1f1c1622f47be30632f6e0fc2fe07a38ab057df447e96b79a87e3362321ae0f3f5a8de98008bf76d479da
pkgname = barrier
+ pkgdesc = Open-source KVM software based on Synergy (GUI)
+ depends = barrier-headless=2.1.2-2
+ depends = qt5-base
+ depends = hicolor-icon-theme
+
+pkgname = barrier-headless
+ pkgdesc = Open-source KVM software based on Synergy (client and server CLI binaries)
diff --git a/CHANGELOG.rst b/CHANGELOG.rst
index 1fa4e260aa0b..0e0236aa5f6e 100644
--- a/CHANGELOG.rst
+++ b/CHANGELOG.rst
@@ -1,5 +1,26 @@
-Changelog for package ``barrier``
-=================================
+Changelog for package base ``barrier``
+======================================
+
+2.1.2-2 - 2018-12-29
+--------------------
+
+- The ``barrier`` package now only contains the Barrier GUI, while
+ a new package ``barrier-headless`` contains the server and client
+ CLI binaries. Users that don't require the GUI can now install only
+ the ``barrier-headless`` package and avoid the ``qt5-base`` dependency
+ required by the Barrier GUI.
+
+ The ``barrier`` package automatically pulls in the ``barrier-headless``
+ package.
+
+2.1.2-1 - 2018-12-29
+--------------------
+
+- Updated to upstream release 2.1.2_, for which there is no upstream
+ changelog available (apart from the VCS history).
+
+**Note:** While this release has been tagged as ``2.1.2`` by upstream,
+the actual version number shown by the Barrier programs is ``2.2.0``.
2.1.1-2 - 2018-05-30
--------------------
@@ -16,4 +37,5 @@ Changelog for package ``barrier``
.. _2.1.1: https://github.com/debauchee/barrier/releases/tag/v2.1.1
+.. _2.1.2: https://github.com/debauchee/barrier/releases/tag/v2.1.2
.. _issue 49: https://github.com/debauchee/barrier/issues/49
diff --git a/PKGBUILD b/PKGBUILD
index f3f20160927a..738f942854d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Tilman BLUMENBACH <tilman+aur AT ax86 DOT net>
-pkgname=barrier
+pkgname=(barrier barrier-headless)
pkgver=2.1.2
-pkgrel=1
+pkgrel=2
pkgdesc="Open-source KVM software based on Synergy"
url="https://github.com/debauchee/barrier"
license=("custom:GPL2WithOpenSSLException")
@@ -25,12 +25,14 @@ depends=(
libsm
libice
openssl
+)
+makedepends=(
+ cmake
# Barrier GUI dependencies:
qt5-base
hicolor-icon-theme
)
-makedepends=(cmake)
prepare() {
cd "barrier-${pkgver?}"
@@ -57,7 +59,7 @@ build() {
make
}
-package() {
+_package_common() {
# Install binaries:
cd "barrier-${pkgver?}/build"
DESTDIR="${pkgdir?}" make install
@@ -75,4 +77,42 @@ package() {
install -m 644 doc/barrier.conf* "${pkgdir?}/usr/share/doc/${pkgname?}"
}
+package_barrier() {
+ pkgdesc="Open-source KVM software based on Synergy (GUI)"
+ depends=(
+ "barrier-headless=${pkgver?}-${pkgrel?}"
+ qt5-base
+ hicolor-icon-theme
+ )
+
+ # Install all the files:
+ _package_common
+
+ # Now go and delete files that are already in
+ # barrier-headless:
+ for file in \
+ /usr/share/doc \
+ /usr/share/man \
+ /usr/bin/barrier{s,c} \
+ ;do
+ rm -rf "${pkgdir:?}/${file:?}"
+ done
+}
+
+package_barrier-headless() {
+ pkgdesc="Open-source KVM software based on Synergy (client and server CLI binaries)"
+
+ # Install all the files:
+ _package_common
+
+ # Now go and delete the GUI-related files:
+ for file in \
+ /usr/bin/barrier \
+ /usr/share/applications \
+ /usr/share/icons \
+ ;do
+ rm -rf "${pkgdir:?}/${file:?}"
+ done
+}
+
sha384sums=('9d3f1e784ca1f1c1622f47be30632f6e0fc2fe07a38ab057df447e96b79a87e3362321ae0f3f5a8de98008bf76d479da')