summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
2 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d74c26d5d9c2..88de491dc2e2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = baru-bin
pkgdesc = A system monitor written in Rust and C
- pkgver = 0.2.6
+ pkgver = 0.2.7
pkgrel = 1
url = https://github.com/doums/baru
arch = x86_64
license = MPL2
depends = libpulse
depends = libnl
- source = baru-bin-0.2.6::https://github.com/doums/baru/releases/download/v0.2.6/baru
- md5sums = 3025f3e7da1ee02e97cd483b4fa8ba04
+ provides = baru
+ conflicts = baru
+ source = baru-bin-0.2.7::https://github.com/doums/baru/releases/download/v0.2.7/baru
+ md5sums = c8b36507c0c22da57d44d4f461416bd3
pkgname = baru-bin
diff --git a/PKGBUILD b/PKGBUILD
index c1a62cb25294..1e1807554b94 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=baru-bin
_pkgname=baru
-pkgver=0.2.6
+pkgver=0.2.7
pkgrel=1
pkgdesc="A system monitor written in Rust and C"
arch=('x86_64')
@@ -10,7 +10,9 @@ url="https://github.com/doums/baru"
license=('MPL2')
source=("$pkgname-$pkgver::https://github.com/doums/baru/releases/download/v${pkgver}/${_pkgname}")
depends=('libpulse' 'libnl')
-md5sums=('3025f3e7da1ee02e97cd483b4fa8ba04')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+md5sums=('c8b36507c0c22da57d44d4f461416bd3')
package() {
install -Dm755 "$pkgname-$pkgver" "$pkgdir/usr/bin/$_pkgname"