summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dc9d301e26e6..95f7a14229ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = barvinok
pkgdesc = A library for counting the number of integer points in parametric and non-parametric polytopes
- pkgver = 0.39
+ pkgver = 0.40
pkgrel = 1
url = http://freecode.com/projects/barvinok
arch = i686
@@ -9,9 +9,8 @@ pkgbase = barvinok
depends = ntl
depends = isl
depends = polylib-gmp
- depends = glpk>4.47
- source = http://barvinok.gforge.inria.fr/barvinok-0.39.tar.xz
- md5sums = d0b6165c4e92b253369f92e6e0be23ef
+ source = http://barvinok.gforge.inria.fr/barvinok-0.40.tar.xz
+ md5sums = a5c0b48b4e336ee652e6e517d14ea9b6
pkgname = barvinok
diff --git a/PKGBUILD b/PKGBUILD
index e56ffb4a5281..651dc89cdbf0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
# Maintainer: Hans-Nikolai Viessmann <hv15 AT hw.ac.uk>
# Category: science
pkgname='barvinok'
-pkgver='0.39'
+pkgver='0.40'
pkgrel=1
pkgdesc='A library for counting the number of integer points in parametric and non-parametric polytopes'
arch=('i686' 'x86_64')
url='http://freecode.com/projects/barvinok'
license=('GPL')
-depends=('ntl' 'isl' 'polylib-gmp' 'glpk>4.47')
+depends=('ntl' 'isl' 'polylib-gmp')
source=("http://barvinok.gforge.inria.fr/$pkgname-$pkgver.tar.xz")
-md5sums=('d0b6165c4e92b253369f92e6e0be23ef')
+md5sums=('a5c0b48b4e336ee652e6e517d14ea9b6')
build() {
cd "$srcdir/$pkgname-$pkgver"
- env CPPFLAGS="-DNTL_STD_CXX" ./configure --prefix=/usr --with-isl=system --with-polylib=system
+ ./configure --prefix=/usr --enable-shared-barvinok --with-isl=system --with-polylib=system
make
}
@@ -24,5 +24,5 @@ check() {
package() {
cd "$srcdir/$pkgname-$pkgver"
- make prefix="$pkgdir"/usr install
+ make DESTDIR="$pkgdir" install
}