summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD25
-rw-r--r--fix-missing-isl-include.patch10
3 files changed, 37 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e2e6c7c93e69..b5796a7d04eb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
pkgbase = barvinok
pkgdesc = A library for counting the number of integer points in parametric and non-parametric polytopes
- pkgver = 0.40
- pkgrel = 2
+ pkgver = 0.41
+ pkgrel = 1
url = http://freecode.com/projects/barvinok
arch = x86_64
license = GPL
depends = ntl
- depends = isl
+ depends = isl>0.17
depends = polylib-gmp
- source = http://barvinok.gforge.inria.fr/barvinok-0.40.tar.xz
- md5sums = a5c0b48b4e336ee652e6e517d14ea9b6
+ source = http://barvinok.gforge.inria.fr/barvinok-0.41.tar.xz
+ source = fix-missing-isl-include.patch
+ md5sums = a5496a4a93f3f1f26fef07189e12314f
+ md5sums = 44a312463a5688031d26e615b8a22594
pkgname = barvinok
diff --git a/PKGBUILD b/PKGBUILD
index 18afe8bf5847..c2fca4b3f73c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,29 @@
# Maintainer: Hans-Nikolai Viessmann <hans AT viess.mn>
pkgname='barvinok'
-pkgver=0.40
-pkgrel=2
+pkgver=0.41
+pkgrel=1
pkgdesc='A library for counting the number of integer points in parametric and non-parametric polytopes'
arch=('x86_64')
url='http://freecode.com/projects/barvinok'
license=('GPL')
-depends=('ntl' 'isl' 'polylib-gmp')
-source=("http://barvinok.gforge.inria.fr/$pkgname-$pkgver.tar.xz")
-md5sums=('a5c0b48b4e336ee652e6e517d14ea9b6')
+depends=('ntl' 'isl>0.17' 'polylib-gmp')
+source=("http://barvinok.gforge.inria.fr/$pkgname-$pkgver.tar.xz"
+ 'fix-missing-isl-include.patch')
+md5sums=('a5496a4a93f3f1f26fef07189e12314f'
+ '44a312463a5688031d26e615b8a22594')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ # because we are building with system ISL, we need to correct a minor oversight, which
+ # is that a dummy library is generated to wrap around all the ISL functions - for bundled
+ # or build case, the linking is handled correctly. For system case the linking does not
+ # include the correct include path. This patch adds the missing include path.
+ patch -p0 < ../fix-missing-isl-include.patch
+
+ # rebuild autotools
+ autoconf -i
+}
build() {
cd "$srcdir/$pkgname-$pkgver"
diff --git a/fix-missing-isl-include.patch b/fix-missing-isl-include.patch
new file mode 100644
index 000000000000..3137ec372ae3
--- /dev/null
+++ b/fix-missing-isl-include.patch
@@ -0,0 +1,10 @@
+--- configure.ac 2018-03-06 22:45:44.000000000 +0200
++++ configure.ac.o 2018-04-20 22:41:21.563884174 +0300
+@@ -157,6 +157,7 @@
+ PACKAGE_CFLAGS_ISL='-I${prefix}/include'
+ ;;
+ system)
++ ISL_SRCDIR="$srcdir/isl"
+ PKG_CHECK_MODULES([ISL], [isl])
+ PACKAGE_CFLAGS_ISL="$ISL_CFLAGS"
+ esac