summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD9
2 files changed, 4 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cb622b2f251f..167360fe9c06 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,6 +6,7 @@ pkgbase = bash-command-timer-git
install = bash-command-timer-git.install
arch = any
license = APACHE
+ makedepends = git
depends = bash-preexec
provides = bash-command-timer
source = bash-command-timer-git-r39.f1b5412::git+https://github.com/jichu4n/bash-command-timer.git#branch=master
diff --git a/PKGBUILD b/PKGBUILD
index bbf961b894a4..23f5deb95e83 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ pkgdesc="Pretty-print execution time for each bash command."
arch=('any')
url="https://github.com/jichu4n/bash-command-timer"
license=('APACHE')
-#makedepends=('')
+makedepends=('git')
depends=('bash-preexec')
source=("${pkgname}-${pkgver}::git+https://github.com/jichu4n/bash-command-timer.git#branch=master")
@@ -24,13 +24,10 @@ pkgver() {
)
}
-#build() {
-#
-#}
-
package() {
cd "$srcdir/$pkgname-$pkgver"
- install -D -m0755 "$srcdir/$pkgname-$pkgver/bash_command_timer.sh" "$pkgdir/usr/share/bash-command-timer/bash_command_timer.sh"
+ install -D -m0755 "$srcdir/$pkgname-$pkgver/bash_command_timer.sh" \
+ "$pkgdir/usr/share/bash-command-timer/bash_command_timer.sh"
}
#