summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD20
-rwxr-xr-xbash-complete-alias.install14
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..32e70e0dadde
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = bash-complete-alias
+ pkgdesc = automagical bash shell alias completion
+ pkgver = 1.7.0
+ pkgrel = 1
+ url = https://repo.cykerway.com/complete-alias
+ install = bash-complete-alias.install
+ arch = any
+ license = GPL3
+ makedepends = git
+ source = git+https://github.com/cykerway/complete-alias.git#tag=1.7.0
+ sha256sums = SKIP
+
+pkgname = bash-complete-alias
+ depends = bash-completion
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..73df5c9ab676
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: tinywrkb <tinywrkb@gmail.com>
+
+_gitname=complete-alias
+pkgname=bash-${_gitname}
+pkgver=1.7.0
+pkgrel=1
+pkgdesc='automagical bash shell alias completion'
+arch=(any)
+url='https://repo.cykerway.com/complete-alias'
+license=('GPL3')
+install=${pkgname}.install
+makedepends=('git')
+source=("git+https://github.com/cykerway/${_gitname}.git#tag=${pkgver}")
+sha256sums=('SKIP')
+
+package() {
+ depends=('bash-completion')
+ install -Dm644 ${_gitname}/complete_alias "${pkgdir}"/usr/share/${pkgname}/complete_alias
+ install -Dm644 ${_gitname}/README.md "${pkgdir}"/usr/share/doc/${pkgname}/README.md
+}
diff --git a/bash-complete-alias.install b/bash-complete-alias.install
new file mode 100755
index 000000000000..66478f551515
--- /dev/null
+++ b/bash-complete-alias.install
@@ -0,0 +1,14 @@
+#!/bin/bash
+
+post_install() {
+ echo
+ echo '==> bash-complete-alias installation notes:'
+ echo
+ echo ' 1. Source /usr/share/bash-complete-alias/complete_alias in your bash config (e.g. ~/.bashrc).'
+ echo
+ echo ' 2. For each alias in your bash config, call the complete builtin with _complete_alias and the name of the alias.'
+ echo ' i.e. complete -F _complete_alias my_alias'
+ echo
+ echo '==> For more details see /usr/share/doc/bash-complete-alias/README.md'
+ echo
+}