summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
-rw-r--r--bash-git-prompt.install6
3 files changed, 14 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 92a6bb5f31fd..792a80805e5a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Sun Oct 30 04:15:43 UTC 2016
pkgbase = bash-git-prompt-git
pkgdesc = Informative git prompt for bash and fish (git version)
- pkgver = 2.6.1.r506.9af8824
+ pkgver = 2.7.1.r584.9c07945
pkgrel = 1
url = https://github.com/magicmonty/bash-git-prompt
install = bash-git-prompt.install
@@ -17,7 +15,7 @@ pkgbase = bash-git-prompt-git
source = bash-git-prompt.install
source = Default_Arch.bgptheme
md5sums = SKIP
- md5sums = 990d3a7ef8a21b83f0d1e90d9ef1a5b7
+ md5sums = 9024256781844b2af5da4da4882e9160
md5sums = af064330b3a579ec6efd2e018e6829df
pkgname = bash-git-prompt-git
diff --git a/PKGBUILD b/PKGBUILD
index a70031dc1c91..5d23ec52afcd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,9 @@
-# $Id$
-# Maintainer: James Harvey <jamespharvey20@gmail.com>
+# Maintainer: James Harvey <jamespharvey20 at gmail dot com>
# * No namcap warnings or errors
pkgname=bash-git-prompt-git
_pkgname=bash-git-prompt
-pkgver=2.6.1.r506.9af8824
+pkgver=2.7.1.r584.9c07945
pkgrel=1
pkgdesc="Informative git prompt for bash and fish (git version)"
arch=('any')
@@ -19,7 +18,7 @@ source=("git+https://github.com/magicmonty/${_pkgname}"
'bash-git-prompt.install'
'Default_Arch.bgptheme')
md5sums=('SKIP'
- '990d3a7ef8a21b83f0d1e90d9ef1a5b7'
+ '9024256781844b2af5da4da4882e9160'
'af064330b3a579ec6efd2e018e6829df')
install='bash-git-prompt.install'
@@ -48,9 +47,15 @@ package() {
install -Dm644 Default_NoExitState.bgptheme ${pkgdir}/usr/lib/${pkgname}/themes/Default_NoExitState.bgptheme
install -Dm644 Evermeet.bgptheme ${pkgdir}/usr/lib/${pkgname}/themes/Evermeet.bgptheme
install -Dm644 Evermeet_Lowres.bgptheme ${pkgdir}/usr/lib/${pkgname}/themes/Evermeet_Lowres.bgptheme
+ install -Dm644 Minimal.bgptheme ${pkgdir}/usr/lib/${pkgname}/themes/Minimal.bgptheme
+ install -Dm644 Minimal_UserHost.bgptheme ${pkgdir}/usr/lib/${pkgname}/themes/Minimal_UserHost.bgptheme
+ install -Dm644 Plague_Doctor.bgptheme ${pkgdir}/usr/lib/${pkgname}/themes/Plague_Doctor.bgptheme
install -Dm644 Single_line.bgptheme ${pkgdir}/usr/lib/${pkgname}/themes/Single_line.bgptheme
+ install -Dm644 Single_line_Dark.bgptheme ${pkgdir}/usr/lib/${pkgname}/themes/Single_line_Dark.bgptheme
+ install -Dm644 Single_line_Minimalist.bgptheme ${pkgdir}/usr/lib/${pkgname}/themes/Single_line_Minimalist.bgptheme
install -Dm644 Single_line_NoExitState.bgptheme ${pkgdir}/usr/lib/${pkgname}/themes/Single_line_NoExitState.bgptheme
install -Dm644 Single_line_Solarized.bgptheme ${pkgdir}/usr/lib/${pkgname}/themes/Single_line_Solarized.bgptheme
+ install -Dm644 Single_line_Solarized_Lamda.bgptheme ${pkgdir}/usr/lib/${pkgname}/themes/Single_line_Solarized_Lamda.bgptheme
install -Dm644 Solarized.bgptheme ${pkgdir}/usr/lib/${pkgname}/themes/Solarized.bgptheme
install -Dm644 Solarized_Extravagant.bgptheme ${pkgdir}/usr/lib/${pkgname}/themes/Solarized_Extravagant.bgptheme
install -Dm644 Solarized_NoExitState.bgptheme ${pkgdir}/usr/lib/${pkgname}/themes/Solarized_NoExitState.bgptheme
diff --git a/bash-git-prompt.install b/bash-git-prompt.install
index 33c1e85df7cc..cef5117be77d 100644
--- a/bash-git-prompt.install
+++ b/bash-git-prompt.install
@@ -4,7 +4,7 @@ post_install() {
NOTE: To use bash-git-prompt, you should add the following to your
/etc/bash.bashrc or ~/.bashrc:
- if [ -f %{/usr/lib/bash-git-prompt/gitprompt.sh ]; then
+ if [ -f /usr/lib/bash-git-prompt/gitprompt.sh ]; then
# To only show the git prompt in or under a repository directory
# GIT_PROMPT_ONLY_IN_REPO=1
# To use upstream's default theme
@@ -17,7 +17,7 @@ post_install() {
NOTE: To have the colors shown by 'git status' match the Default_Arch theme,
add the following to your ~/.gitconfig:
- [color "status"]
+ [color \"status\"]
branch = magenta
untracked = cyan
unmerged = yellow
@@ -37,7 +37,7 @@ post_remove() {
by doing one of the following:
* Restarting your shells (relogging in each of them)
- * Starting new shells (running "bash" in each of them)
+ * Starting new shells (running \"bash\" in each of them)
* Rebooting
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^