summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--Default_Arch.bgptheme16
-rw-r--r--PKGBUILD17
-rw-r--r--bash-git-prompt.install6
4 files changed, 28 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 40985d1fa280..1897278616ab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -13,10 +13,10 @@ pkgbase = bash-git-prompt-git
conflicts = bash-git-prompt
source = git+https://github.com/magicmonty/bash-git-prompt
source = bash-git-prompt.install
- source = removed_spacing.patch
+ source = Default_Arch.bgptheme
md5sums = SKIP
- md5sums = 1e762bd413b6efdec225928da5aa6451
- md5sums = 513706d4f97f775a60325bc31574d197
+ md5sums = db6f83999124b7fa660310a8d6624f70
+ md5sums = 8e4f18f5cfb65bdc5a94adb0477188ce
pkgname = bash-git-prompt-git
diff --git a/Default_Arch.bgptheme b/Default_Arch.bgptheme
new file mode 100644
index 000000000000..b39a1720fe5c
--- /dev/null
+++ b/Default_Arch.bgptheme
@@ -0,0 +1,16 @@
+# This is the default theme for gitprompt.sh
+# with removed spacing only necessary on other operating systems
+# and username and hostname displayed
+
+override_git_prompt_colors() {
+ GIT_PROMPT_THEME_NAME="Default Arch"
+ GIT_PROMPT_CONFLICTS="${Red}✖"
+ GIT_PROMPT_CHANGED="${Blue}✚"
+ GIT_PROMPT_STASHED="${BoldBlue}⚑"
+ GIT_PROMPT_SYMBOLS_AHEAD="↑"
+ GIT_PROMPT_SYMBOLS_BEHIND="↓"
+ GIT_PROMPT_END_USER=" \n${White}[\u@\h] ${Time12a}${ResetColor} $ "
+ GIT_PROMPT_END_USER=" \n${White}[\u@\h] ${Time12a}${ResetColor} # "
+}
+
+reload_git_prompt_colors "Default Arch"
diff --git a/PKGBUILD b/PKGBUILD
index f2acfb18bc35..424c2fbe7cd5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,26 +25,16 @@ conflicts=('bash-git-prompt')
license=('custom:BSD 2 Clause (NetBSD)')
source=("git+https://github.com/magicmonty/${_pkgname}"
'bash-git-prompt.install'
- 'removed_spacing.patch')
+ 'Default_Arch.bgptheme')
md5sums=('SKIP'
- '1e762bd413b6efdec225928da5aa6451'
- '513706d4f97f775a60325bc31574d197')
+ 'db6f83999124b7fa660310a8d6624f70'
+ '8e4f18f5cfb65bdc5a94adb0477188ce')
install='bash-git-prompt.install'
pkgrel() {
echo $(cat bash-git-prompt.rb | grep url | sed 's|.*archive/||' | sed 's|.tar.gz"$||').r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)
}
-prepare() {
- if [ -n "$_install_removed_spacing_patch" ]; then
- cd ${srcdir}/${_pkgname}
- echo "Installing removed_spacing.patch..."
- patch -p1 -i ${srcdir}/removed_spacing.patch
- else
- echo "NOT installing removed_spacing.patch..."
- fi
-}
-
package() {
cd ${srcdir}/${_pkgname}
@@ -59,6 +49,7 @@ package() {
cd themes
install -Dm644 Custom.bgptemplate ${pkgdir}/usr/lib/${_pkgname}/themes/Custom.bgptemplate
install -Dm644 Default.bgptheme ${pkgdir}/usr/lib/${_pkgname}/themes/Default.bgptheme
+ install -Dm644 ${srcdir}/Default_Arch.bgptheme ${pkgdir}/usr/lib/${_pkgname}/themes/Default_Arch.bgptheme
install -Dm644 Default_NoExitState.bgptheme ${pkgdir}/usr/lib/${_pkgname}/themes/Default_NoExitState.bgptheme
install -Dm644 Single_line.bgptheme ${pkgdir}/usr/lib/${_pkgname}/themes/Single_line.bgptheme
install -Dm644 Single_line_openSUSE.bgptheme ${pkgdir}/usr/lib/${_pkgname}/themes/Single_line_openSUSE.bgptheme
diff --git a/bash-git-prompt.install b/bash-git-prompt.install
index 9596c0fe74cd..ef7e4ffecdf1 100644
--- a/bash-git-prompt.install
+++ b/bash-git-prompt.install
@@ -5,8 +5,12 @@ post_install() {
/etc/bash.bashrc or ~/.bashrc:
if [ -f %{/usr/lib/bash-git-prompt/gitprompt.sh ]; then
+ # To only show the git prompt in or under a repository directory
# GIT_PROMPT_ONLY_IN_REPO=1
- GIT_PROMPT_THEME=Default
+ # To use upstream's default theme
+ # GIT_PROMPT_THEME=Default
+ # To use upstream's default theme, modified by arch maintainer
+ GIT_PROMPT_THEME=Default_Arch
source /usr/lib/bash-git-prompt/gitprompt.sh
fi