summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD16
2 files changed, 6 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8f1b9613f8f9..40e041a8e7b0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = bash_unit
pkgdesc = bash unit testing enterprise edition framework for professionals
- pkgver = 1.6.0
+ pkgver = 1.6.1
pkgrel = 1
url = https://github.com/pgrange/bash_unit
arch = any
license = GPL
depends = bash
- source = git+https://github.com/pgrange/bash_unit.git
+ source = https://github.com/pgrange/bash_unit/archive/v1.6.1.tar.gz
md5sums = SKIP
pkgname = bash_unit
diff --git a/PKGBUILD b/PKGBUILD
index e7e535fbe1d7..73e5a09bbe09 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,17 @@
# Maintainer: n0vember <n0vember at half-9 dot net>
pkgname=bash_unit
-pkgver=1.6.0
+pkgver=1.6.1
pkgrel=1
pkgdesc="bash unit testing enterprise edition framework for professionals"
arch=('any')
url="https://github.com/pgrange/bash_unit"
license=('GPL')
depends=('bash')
-source=(git+https://github.com/pgrange/bash_unit.git)
+source=("https://github.com/pgrange/${pkgname}/archive/v${pkgver}.tar.gz")
md5sums=('SKIP')
-build() {
- cd "$pkgname"
- git checkout tags/v$pkgver -b v$pkgver
-}
-
package() {
- cd "$pkgname"
-
- install -Dm755 -o root -g root bash_unit "$pkgdir/usr/bin/bash_unit"
-
+ install -Dm755 -o root -g root ${pkgname}-${pkgver}/bash_unit "$pkgdir/usr/bin/bash_unit"
install -dm755 ${pkgdir}/usr/share/man/man1
- cp -dpr --no-preserve=ownership docs/man/man1/*.1 "$pkgdir/usr/share/man/man1"
+ cp -dpr --no-preserve=ownership ${pkgname}-${pkgver}/docs/man/man1/*.1 "$pkgdir/usr/share/man/man1"
}