summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD26
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6d2486eb6ee4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = bashbc-git
+ pkgdesc = Command-line calculator in pure BASH
+ pkgver = r3.ec9133d
+ pkgrel = 1
+ url = https://github.com/bluebat/.bash
+ arch = any
+ license = GPL
+ makedepends = git
+ provides = bashbc
+ conflicts = bashbc
+ source = bashbc::git+https://github.com/bluebat/.bash.git
+ sha256sums = SKIP
+
+pkgname = bashbc-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3b93442f9195
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+
+_pkgname='bashbc'
+pkgname="${_pkgname}-git"
+pkgver=r3.ec9133d
+pkgrel=1
+pkgdesc='Command-line calculator in pure BASH'
+arch=('any')
+url='https://github.com/bluebat/.bash'
+license=('GPL')
+makedepends=('git')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("${_pkgname}::git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ install -Dm755 "${_pkgname}/${_pkgname}.sh" "${pkgdir}/usr/bin/${_pkgname}"
+}
+
+# vim: ts=2 sw=2 et: