summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD35
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..23d65aa6f966
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Fri Dec 28 07:40:13 UTC 2018
+pkgbase = bashcaster-git
+ pkgdesc = Bashcaster is a simple script that uses ffmpeg to record screencasts to videos or GIFs. It can record the whole screen or a window. It can optionally optimize GIFs with gifsicle.
+ pkgver = r7.5c2e454
+ pkgrel = 1
+ url = https://github.com/alphapapa/bashcaster
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = ffmpeg
+ depends = xorg-xprop
+ depends = xorg-xwininfo
+ depends = yad
+ optdepends = gifsicle
+ conflicts = bashcaster
+ source = bashcaster::git+https://github.com/alphapapa/bashcaster.git
+ sha512sums = SKIP
+
+pkgname = bashcaster-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cfd541fa1cf5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Chris Mullins <christopher.r.mullins gmail>
+
+_pkgname=bashcaster
+pkgname=${_pkgname}-git
+pkgver=r7.5c2e454
+pkgrel=1
+pkgdesc="Bashcaster is a simple script that uses ffmpeg to record screencasts to videos or GIFs. It can record the whole screen or a window. It can optionally optimize GIFs with gifsicle.
+"
+arch=("any")
+
+url="https://github.com/alphapapa/bashcaster"
+license=("GPL3")
+
+depends=("ffmpeg" "xorg-xprop" "xorg-xwininfo" "yad")
+optdepends=("gifsicle")
+makedepends=("git")
+conflicts=("${_pkgname}")
+
+source=(
+ "${_pkgname}::git+https://github.com/alphapapa/${_pkgname}.git"
+)
+sha512sums=(
+ "SKIP"
+)
+pkgver() {
+ cd "${_pkgname}"
+ printf "r%s.%s\n" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${_pkgname}"
+
+ install -m755 -D "bashcaster.sh" "$pkgdir/usr/bin/bashcaster"
+ install -m644 -D "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}