summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD30
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..295f4f9bec18
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Tue May 16 07:27:02 UTC 2017
+pkgbase = batcli-git
+ pkgdesc = Bat is a CLI cURL-like tool for humans inspired by Httpie and written in Go.
+ pkgver = 0.0.1.r9.gcba1c6b
+ pkgrel = 1
+ url = https://github.com/astaxie/bat
+ arch = x86_64
+ arch = i686
+ license = APACHE
+ makedepends = go
+ options = !strip
+ options = !emptydirs
+ source = bat::git+https://github.com/astaxie/bat.git
+ sha256sums = SKIP
+
+pkgname = batcli-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7f9beb9f7c64
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: afontenot <adam.m.fontenot@gmail.com>
+
+pkgname=batcli-git
+pkgver=0.0.1.r9.gcba1c6b
+pkgrel=1
+pkgdesc="Bat is a CLI cURL-like tool for humans inspired by Httpie and written in Go."
+arch=('x86_64' 'i686')
+url="https://github.com/astaxie/bat"
+license=('APACHE')
+makedepends=('go')
+options=('!strip' '!emptydirs')
+source=("bat::git+https://github.com/astaxie/bat.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "bat"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "bat"
+ sed -i 's/github.com\/astaxie\/bat\//.\//' http.go
+ sed -i 's/github.com\/astaxie\/bat\//.\//' bench.go
+ go build
+}
+
+package() {
+ cd "bat"
+ install -Dm755 "bat" "$pkgdir/usr/bin/bat"
+}