summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD27
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bd3c06478356
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = batsh
+ pkgdesc = A language that compiles to Bash and Windows Batch
+ pkgver = 0.0.6
+ pkgrel = 1
+ url = https://github.com/BYVoid/Batsh
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = ocp-build
+ depends = ocaml
+ depends = ocaml-core
+ depends = ocaml-ounit
+ depends = ocaml-dlist
+ depends = ocaml-cmdliner
+ options = !strip
+ source = https://github.com/BYVoid/Batsh/archive/v0.0.6.tar.gz
+ md5sums = aeb8a3a6b6c7c9de8b041dc9023b6a1a
+
+pkgname = batsh
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..29bc5a4d67a6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+
+pkgname=batsh
+pkgver=0.0.6
+pkgrel=1
+license=('MIT')
+arch=('i686' 'x86_64')
+pkgdesc="A language that compiles to Bash and Windows Batch"
+url="https://github.com/BYVoid/Batsh"
+depends=('ocaml' 'ocaml-core' 'ocaml-ounit' 'ocaml-dlist' 'ocaml-cmdliner')
+makedepends=('ocp-build')
+source=("https://github.com/BYVoid/Batsh/archive/v${pkgver}.tar.gz")
+options=('!strip')
+md5sums=('aeb8a3a6b6c7c9de8b041dc9023b6a1a')
+
+build() {
+ cd "${srcdir}/Batsh-${pkgver}/src"
+
+ ocp-build init
+ ocp-build build
+}
+
+package() {
+ cd "${srcdir}/Batsh-${pkgver}/src"
+
+ ocp-build install -install-destdir $pkgdir
+}