summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore17
-rw-r--r--PKGBUILD25
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ebf1dcaa8232
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = battery-checker-git
+ pkgdesc = Script determining if the laptop battery is low
+ pkgver = 1.1
+ pkgrel = 1
+ url = https://gitlab.com/daersc/battery-checker
+ arch = any
+ license = GPL3
+ depends = libnotify
+ provides = battery-checker
+ conflicts = battery-checker
+ source = git+https://gitlab.com/daersc/battery-checker.git
+ md5sums = SKIP
+
+pkgname = battery-checker-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0fe86333a93d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,17 @@
+#
+# Source files downloaded during makepkg
+#
+/battery-checker/
+
+#
+# Files and directories generated by the Arch Build System
+#
+# /src/ Directory with extracted sources
+# /pkg/ Directory for staging installation files
+# /*.pkg.tar.xz Generated installation file for pacman
+# /*.pkg.tar.xz.sig Signature of the package file
+#
+/src/
+/pkg/
+/*.pkg.tar.xz
+/*.pkg.tar.xz.sig
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1ff542cc62cf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: David Schury <dasc@posteo.de>
+
+pkgname=battery-checker-git
+_pkgname=battery-checker
+pkgver=1.1
+pkgrel=1
+pkgdesc="Script determining if the laptop battery is low"
+url="https://gitlab.com/daersc/battery-checker"
+arch=('any')
+license=('GPL3')
+depends=('libnotify')
+conflicts=('battery-checker')
+provides=('battery-checker')
+source=("git+https://gitlab.com/daersc/$_pkgname.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $srcdir/$_pkgname
+ git describe --tags | sed -e 's|-|.|g' -e 's|^v||'
+}
+
+package() {
+ mkdir -p $pkgdir/usr/bin
+ cp $srcdir/$_pkgname/check-battery $pkgdir/usr/bin
+}