summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--battle-isle-gog.sh6
3 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9dd43fecf735..8432e5ac3a6f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = battle-isle-gog
pkgdesc = A turn-based tactics game which tells the story about the wars on the fictional planet, Chromos.
pkgver = 1.0
- pkgrel = 2
+ pkgrel = 3
url = https://www.gog.com/game/battle_isle_platinum
install = battle-isle-gog.install
arch = any
@@ -21,7 +21,7 @@ pkgbase = battle-isle-gog
source = fix-permissions.sh
sha256sums = 2fd4aab428ef7b676166b1661f14f65d4c98f4e9de8f18c17208ed5c42b8764d
sha256sums = 4b8d7b31fafefed19524cfd0fdf8a4f5a2761b1f173d6174859beab4e158003e
- sha256sums = af790b1d9080caedaab6e984ee7b403cc87720fc172d987c04109a5abcb7b96f
+ sha256sums = a95521ea627b5a0ab6a61e72a6bdcc7a4806181dc930be9d4a574eee4e146f51
sha256sums = 2d558ff949d959525a568089d08595b673cc5241bfa1ae130a423ce3b1b6ca36
sha256sums = a6cf2153a01f11ff2de01210db2739d36d4e6a4f93841b227df1d023ed953382
sha256sums = 7145cbfea303b682e415cfe020da23021ac5b04693a17fff74352c59556d40b1
diff --git a/PKGBUILD b/PKGBUILD
index 260824c9dfd7..4fdd74944ce0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=battle-isle-gog
pkgver=1.0
-pkgrel=2
+pkgrel=3
pkgdesc="A turn-based tactics game which tells the story about the wars on the fictional planet, Chromos."
url="https://www.gog.com/game/battle_isle_platinum"
license=('custom:eula')
@@ -24,7 +24,7 @@ source=("setup_battle_isle_${pkgver}_(28043).exe"::"gogdownloader://battle_isle/
sha256sums=('2fd4aab428ef7b676166b1661f14f65d4c98f4e9de8f18c17208ed5c42b8764d'
'4b8d7b31fafefed19524cfd0fdf8a4f5a2761b1f173d6174859beab4e158003e'
- 'af790b1d9080caedaab6e984ee7b403cc87720fc172d987c04109a5abcb7b96f'
+ 'a95521ea627b5a0ab6a61e72a6bdcc7a4806181dc930be9d4a574eee4e146f51'
'2d558ff949d959525a568089d08595b673cc5241bfa1ae130a423ce3b1b6ca36'
'a6cf2153a01f11ff2de01210db2739d36d4e6a4f93841b227df1d023ed953382'
'7145cbfea303b682e415cfe020da23021ac5b04693a17fff74352c59556d40b1'
diff --git a/battle-isle-gog.sh b/battle-isle-gog.sh
index af6112501610..efe989fa8ed4 100644
--- a/battle-isle-gog.sh
+++ b/battle-isle-gog.sh
@@ -14,6 +14,7 @@ cat <<EOF
$script --windowed
$script --addon moon
$script --windowed --desert
+ DOSBOX_CMD=dosbox-x $script
EOF
exit 0
}
@@ -23,6 +24,7 @@ popd() { builtin popd > /dev/null; }
INSTALL_DIR=/opt/battle-isle
HOME_DIR="$HOME"/.gog/battle-isle
+DOSBOX_CMD=${DOSBOX_CMD:-dosbox}
if which unionfs &> /dev/null; then
USE_UNIONFS=1
@@ -76,9 +78,9 @@ if [ "$USE_UNIONFS" ]; then
unionfs -o cow,relaxed_permissions "$UPPER_DIR=RW:$LOWER_DIR=RO" "$UNION_DIR"
echo "Launching game within $UNION_DIR"
- pushd "$UNION_DIR" && dosbox "${configs[@]}"
+ pushd "$UNION_DIR" && "$DOSBOX_CMD" "${configs[@]}"
popd && fusermount -u "$UNION_DIR"
else
echo "Launching game within $INSTALL_DIR"
- cd $INSTALL_DIR && dosbox "${configs[@]}"
+ cd $INSTALL_DIR && "$DOSBOX_CMD" "${configs[@]}"
fi