summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD35
-rw-r--r--battle-isle-gog.sh8
3 files changed, 20 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 28bb5a191b54..29f88e729407 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = battle-isle-gog
pkgdesc = A turn-based tactics game which tells the story about the wars on the fictional planet, Chromos.
- pkgver = 2.2.0.21
+ pkgver = 1.0
pkgrel = 1
url = https://www.gog.com/game/battle_isle_platinum
install = battle-isle-gog.install
@@ -11,25 +11,21 @@ pkgbase = battle-isle-gog
makedepends = icoutils
depends = dosbox
optdepends = unionfs-fuse: mounting game folder to home for savegames and settings
- source = setup_battle_isle_2.2.0.21.exe::gogdownloader://battle_isle/installer_win_en
+ source = setup_battle_isle_1.0_(28043).exe::gogdownloader://battle_isle/installer_win_en
source = battle-isle-gog.desktop
source = battle-isle-gog.sh
source = dosboxbi1_main.conf
source = dosboxbi1_desert.conf
source = dosboxbi1_moon.conf
source = dosbox_windowed.conf
- source = fix-console-output.patch
- source = fix-dosbox-mounts.patch
source = fix-permissions.sh
- sha256sums = f3886b2700bfa47c8f5d9bb4a888509c3bfc1df688b711a92e12c5a76354e711
+ sha256sums = 2fd4aab428ef7b676166b1661f14f65d4c98f4e9de8f18c17208ed5c42b8764d
sha256sums = 4b8d7b31fafefed19524cfd0fdf8a4f5a2761b1f173d6174859beab4e158003e
- sha256sums = b6868126d238ab28c8a84f9a2c4591dc204b0aba1f6e7499e46523861b539399
+ sha256sums = af790b1d9080caedaab6e984ee7b403cc87720fc172d987c04109a5abcb7b96f
sha256sums = 2d558ff949d959525a568089d08595b673cc5241bfa1ae130a423ce3b1b6ca36
sha256sums = a6cf2153a01f11ff2de01210db2739d36d4e6a4f93841b227df1d023ed953382
sha256sums = 7145cbfea303b682e415cfe020da23021ac5b04693a17fff74352c59556d40b1
sha256sums = 50b601b33522677a9bcaf23edc833329067bb87ccda33039c0b95f0d4ddca578
- sha256sums = 1a11e5ecfdd602ce3412633bac3cfc6160a9b6039af407446d98000d34744ef6
- sha256sums = 557c175620829a0b63d8bd4933ed114d88d6d00f83cda9791332bf1e0e68ed0a
sha256sums = 7e54dbe4aa0c5050afb7459e0faa1e3cf5c8a3c6747cca834d3acd00941add54
pkgname = battle-isle-gog
diff --git a/PKGBUILD b/PKGBUILD
index b6106b2d984d..cff51ac90c91 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Constantin Nickel <constantin dot nickel at gmail dot com>
pkgname=battle-isle-gog
-pkgver=2.2.0.21
+pkgver=1.0
pkgrel=1
pkgdesc="A turn-based tactics game which tells the story about the wars on the fictional planet, Chromos."
url="https://www.gog.com/game/battle_isle_platinum"
@@ -13,26 +13,22 @@ depends=('dosbox')
optdepends=('unionfs-fuse: mounting game folder to home for savegames and settings')
install=$pkgname.install
-source=("setup_battle_isle_$pkgver.exe"::"gogdownloader://battle_isle/installer_win_en"
+source=("setup_battle_isle_${pkgver}_(28043).exe"::"gogdownloader://battle_isle/installer_win_en"
"battle-isle-gog.desktop"
"battle-isle-gog.sh"
"dosboxbi1_main.conf"
"dosboxbi1_desert.conf"
"dosboxbi1_moon.conf"
"dosbox_windowed.conf"
- "fix-console-output.patch"
- "fix-dosbox-mounts.patch"
"fix-permissions.sh")
-sha256sums=('f3886b2700bfa47c8f5d9bb4a888509c3bfc1df688b711a92e12c5a76354e711'
+sha256sums=('2fd4aab428ef7b676166b1661f14f65d4c98f4e9de8f18c17208ed5c42b8764d'
'4b8d7b31fafefed19524cfd0fdf8a4f5a2761b1f173d6174859beab4e158003e'
- 'b6868126d238ab28c8a84f9a2c4591dc204b0aba1f6e7499e46523861b539399'
+ 'af790b1d9080caedaab6e984ee7b403cc87720fc172d987c04109a5abcb7b96f'
'2d558ff949d959525a568089d08595b673cc5241bfa1ae130a423ce3b1b6ca36'
'a6cf2153a01f11ff2de01210db2739d36d4e6a4f93841b227df1d023ed953382'
'7145cbfea303b682e415cfe020da23021ac5b04693a17fff74352c59556d40b1'
'50b601b33522677a9bcaf23edc833329067bb87ccda33039c0b95f0d4ddca578'
- '1a11e5ecfdd602ce3412633bac3cfc6160a9b6039af407446d98000d34744ef6'
- '557c175620829a0b63d8bd4933ed114d88d6d00f83cda9791332bf1e0e68ed0a'
'7e54dbe4aa0c5050afb7459e0faa1e3cf5c8a3c6747cca834d3acd00941add54')
# You need to download the gog.com installer file to this directory ($PWD),
@@ -44,39 +40,36 @@ DLAGENTS+=('gogdownloader::/usr/bin/awk BEGIN{print"Please\ download\ the\ file\
prepare() {
# extract installer (convert files to lowercase, as DOS does not care)
- innoextract -e -L -d "$srcdir" setup_battle_isle_$pkgver.exe
+ innoextract -e -L -d "$srcdir"/setup "setup_battle_isle_${pkgver}_(28043).exe"
# convert icon
- icotool -x app/goggame-1207660993.ico
+ icotool -x setup/goggame-1207660993.ico
# create launchers
sed "s|Exec=battle-isle|& --desert|;s|Name=Battle Isle|&: The Desert|" \
$pkgname.desktop > battle-isle-desert.desktop
sed "s|Exec=battle-isle|& --moon|;s|Name=Battle Isle|&: The Moon of Chromos|" \
$pkgname.desktop > battle-isle-moon.desktop
+
+ cp setup/__support/app/dosboxbi1.conf "$srcdir"
+ cp setup/tmp/eula.txt "$srcdir"
+
# remove bundled dosbox, windows stuff and gog client files
- rm -rf app/{dosbox/,*.ico,*.dll,goggame-1207660993.*,*.zip,__support}
- # fix broken console output
- patch -p1 -i "$srcdir"/fix-console-output.patch
- # fix mount directory
- patch -p1 -i "$srcdir"/fix-dosbox-mounts.patch
+ rm -rf setup/{app,commonappdata,dosbox,tmp,*.ico,*.dll,goggame-1207660993.*,*.zip,__redist,__support}
}
package() {
# data
install -d "$pkgdir"/opt/battle-isle
- cp -r app/* "$pkgdir"/opt/battle-isle
+ cp -r setup/* "$pkgdir"/opt/battle-isle
# fix permissions script
install -Dm755 fix-permissions.sh "$pkgdir"/opt/battle-isle
# additional dosbox configs
- install -m644 dosbox_windowed.conf "$pkgdir"/opt/battle-isle
- install -m644 dosboxbi1_main.conf "$pkgdir"/opt/battle-isle
- install -m644 dosboxbi1_desert.conf "$pkgdir"/opt/battle-isle
- install -m644 dosboxbi1_moon.conf "$pkgdir"/opt/battle-isle
+ install -m644 *.conf "$pkgdir"/opt/battle-isle
# doc + licenses
install -d "$pkgdir"/usr/share/{doc,licenses}/$pkgname
for _f in app/*.pdf; do
ln -s -t "$pkgdir"/usr/share/doc/$pkgname "/opt/battle-isle/$(basename "$_f")"
done
- install -m644 tmp/{gog_,}eula.txt "$pkgdir"/usr/share/licenses/$pkgname
+ install -m644 eula.txt "$pkgdir"/usr/share/licenses/$pkgname
# .desktop files and launchers
install -Dm644 $pkgname.desktop "$pkgdir"/usr/share/applications/battle-isle.desktop
install -Dm755 $pkgname.sh "$pkgdir"/usr/bin/battle-isle
diff --git a/battle-isle-gog.sh b/battle-isle-gog.sh
index e5cb881c4518..af6112501610 100644
--- a/battle-isle-gog.sh
+++ b/battle-isle-gog.sh
@@ -6,7 +6,6 @@ cat <<EOF
Options:
-h --help Show this message
--windowed Windowed mode
- --single
--addon [desert|moon] Start addon The Desert or The Moon of Chromos
--desert Start Battle Isle: The Desert
--moon Start Battle Isle: The Moon of Chromos
@@ -31,7 +30,7 @@ fi
script=${0##*/}
-TEMP=$(getopt -o h --long help,windowed,single,addon:,moon,desert \
+TEMP=$(getopt -o h --long help,windowed,addon:,moon,desert \
-n "$script" -- "$@")
if [ $? != 0 ] ; then exit 1 ; fi
@@ -42,7 +41,6 @@ while true; do
case "$1" in
-h|--help) _help; shift ;;
--windowed) WINDOWED=1; shift ;;
- --single) START_SINGLE=1; shift ;;
--addon)
case "$2" in
desert) START_DESERT=1 ;;
@@ -62,9 +60,7 @@ if [ "$WINDOWED" ]; then
configs+=('-conf' 'dosbox_windowed.conf')
fi
-if [ "$START_SINGLE" ] ; then
- configs+=('-conf' 'dosboxbi1_single.conf')
-elif [ "$START_DESERT" ] ; then
+if [ "$START_DESERT" ] ; then
configs+=('-conf' 'dosboxbi1_desert.conf')
elif [ "$START_MOON" ] ; then
configs+=('-conf' 'dosboxbi1_moon.conf')