summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD6
-rw-r--r--battle-isle2-gog.sh6
3 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 974408f3dcd7..283984db3a33 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = battle-isle2-gog
pkgdesc = A turn-based tactics game which tells the story about the wars on the fictional planet, Chromos.
pkgver = 1.0
- pkgrel = 1
+ pkgrel = 3
url = https://www.gog.com/game/battle_isle_platinum
install = battle-isle2-gog.install
arch = any
groups = games
license = custom:eula
- makedepends = innoextract-git
+ makedepends = innoextract
makedepends = icoutils
depends = dosbox
optdepends = unionfs-fuse: mounting game folder to home for savegames and settings
@@ -20,7 +20,7 @@ pkgbase = battle-isle2-gog
source = fix-image-cue.patch
source = fix-permissions.sh
sha256sums = cbb7bef8cbac55e6b29468ad84c956b55be5bf2792e5986544617f5af3af607b
- sha256sums = 7cad76a7579457e41e7ea29096c1eda0aa5b57d5173973083c86190bb7cb7140
+ sha256sums = 5c0a4bbb146a98f51e6c2de791febaa98350a0b4deaecef613ba05e8f45c6859
sha256sums = bb5c13954638d030c740805153aa25db3f94b21e0acef895022f1967d796fed4
sha256sums = 0331176b6b3e5505cb81e805cd90a3130bd861403b300b46ca7445aab4b2ca1a
sha256sums = 9407e1f77e8ccf1ed20504c42ce13560938e0d5b2412ae249d578a96acad8719
@@ -29,4 +29,3 @@ pkgbase = battle-isle2-gog
sha256sums = f85afa50c4adaf6c9c160da79b6ad77eadf334813f7bdb90eccbaf25bf85d54f
pkgname = battle-isle2-gog
-
diff --git a/PKGBUILD b/PKGBUILD
index 2629364b9f4f..e1c73e548d7c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
pkgname=battle-isle2-gog
pkgver=1.0
-pkgrel=1
+pkgrel=3
pkgdesc="A turn-based tactics game which tells the story about the wars on the fictional planet, Chromos."
url="https://www.gog.com/game/battle_isle_platinum"
license=('custom:eula')
groups=('games')
arch=('any')
-makedepends=('innoextract-git' 'icoutils')
+makedepends=('innoextract' 'icoutils')
depends=('dosbox')
optdepends=('unionfs-fuse: mounting game folder to home for savegames and settings')
install=$pkgname.install
@@ -23,7 +23,7 @@ source=("setup_battle_isle_2_${pkgver}_(28043).exe"::"gogdownloader://battle_isl
"fix-permissions.sh")
sha256sums=('cbb7bef8cbac55e6b29468ad84c956b55be5bf2792e5986544617f5af3af607b'
- '7cad76a7579457e41e7ea29096c1eda0aa5b57d5173973083c86190bb7cb7140'
+ '5c0a4bbb146a98f51e6c2de791febaa98350a0b4deaecef613ba05e8f45c6859'
'bb5c13954638d030c740805153aa25db3f94b21e0acef895022f1967d796fed4'
'0331176b6b3e5505cb81e805cd90a3130bd861403b300b46ca7445aab4b2ca1a'
'9407e1f77e8ccf1ed20504c42ce13560938e0d5b2412ae249d578a96acad8719'
diff --git a/battle-isle2-gog.sh b/battle-isle2-gog.sh
index 457fdb19e65f..794c721abab5 100644
--- a/battle-isle2-gog.sh
+++ b/battle-isle2-gog.sh
@@ -11,6 +11,7 @@ cat <<EOF
$script --windowed
$script --addon
+ DOSBOX_CMD=dosbox-x $script
EOF
exit 0
}
@@ -20,6 +21,7 @@ popd() { builtin popd > /dev/null; }
INSTALL_DIR=/opt/battle-isle2
HOME_DIR="$HOME"/.gog/battle-isle2
+DOSBOX_CMD=${DOSBOX_CMD:-dosbox}
if which unionfs &> /dev/null; then
USE_UNIONFS=1
@@ -63,9 +65,9 @@ if [ "$USE_UNIONFS" ]; then
unionfs -o cow,relaxed_permissions "$UPPER_DIR=RW:$LOWER_DIR=RO" "$UNION_DIR"
echo "Launching game within $UNION_DIR"
- pushd "$UNION_DIR" && dosbox "${configs[@]}"
+ pushd "$UNION_DIR" && "$DOSBOX_CMD" "${configs[@]}"
popd && fusermount -u "$UNION_DIR"
else
echo "Launching game within $INSTALL_DIR"
- cd $INSTALL_DIR && dosbox "${configs[@]}"
+ cd $INSTALL_DIR && "$DOSBOX_CMD" "${configs[@]}"
fi