summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD36
2 files changed, 26 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index da2801514224..f8eeed042a6c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,19 @@
pkgbase = battlestar
pkgdesc = Programming language for creating tiny executables
- pkgver = 0.51
- pkgrel = 1
- url = http://github.com/xyproto/battlestar
+ pkgver = 0.7.0
+ pkgrel = 2
+ url = https://github.com/xyproto/battlestar
arch = x86_64
- arch = i686
- license = MIT
- makedepends = go
+ license = BSD
makedepends = git
- depends = yasm
+ makedepends = go
depends = gcc
+ depends = yasm
optdepends = elfkickers: for smaller executables
optdepends = dosbox: for running 16-bit programs
- optdepends = qemu-arch-extra: for running bootable kernels
optdepends = nasm: for ndisasm and com2bts
- source = git+https://github.com/xyproto/battlestar.git#tag=0.51
- md5sums = SKIP
+ optdepends = qemu-arch-extra: for running bootable kernels
+ source = git+https://github.com/xyproto/battlestar#commit=deb78a26b141531abe6cdc5cd980691e3a41ec46
+ b2sums = SKIP
pkgname = battlestar
-
diff --git a/PKGBUILD b/PKGBUILD
index 7b01bd30d3b9..9a5c1c12f2a1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,35 @@
-# Maintainer: Alexander F Rødseth <xyproto@archlinux.org>
+# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
pkgname=battlestar
-pkgver=0.51
-pkgrel=1
+pkgver=0.7.0
+pkgrel=2
pkgdesc='Programming language for creating tiny executables'
-arch=('x86_64' 'i686')
-url='http://github.com/xyproto/battlestar'
-license=('MIT')
-makedepends=('go' 'git')
-depends=('yasm' 'gcc')
+arch=(x86_64)
+url='https://github.com/xyproto/battlestar'
+license=(BSD)
+makedepends=(git go)
+depends=(gcc yasm)
optdepends=('elfkickers: for smaller executables'
'dosbox: for running 16-bit programs'
- 'qemu-arch-extra: for running bootable kernels'
- 'nasm: for ndisasm and com2bts')
-source=("git+https://github.com/xyproto/battlestar.git#tag=$pkgver")
-md5sums=('SKIP')
+ 'nasm: for ndisasm and com2bts'
+ 'qemu-arch-extra: for running bootable kernels')
+source=("git+$url#commit=deb78a26b141531abe6cdc5cd980691e3a41ec46")
+b2sums=('SKIP')
build() {
- make -C "$pkgname"
+ cd $pkgname/cmd/battlestarc
+ go build -buildmode=pie -ldflags="-s -w -extldflags \"${LDFLAGS}\"" -mod=vendor -trimpath -v
}
package() {
- cd "$pkgname"
-
- make install DESTDIR="$pkgdir"
+ cd $pkgname
+ make DESTDIR="$pkgdir" install
install -d "$pkgdir/usr/share/doc/$pkgname"
cp -r samples "$pkgdir/usr/share/doc/$pkgname/"
cp -r samples64 "$pkgdir/usr/share/doc/$pkgname/"
cp -r samples32 "$pkgdir/usr/share/doc/$pkgname/"
cp -r samples16 "$pkgdir/usr/share/doc/$pkgname/"
cp -r helloworld "$pkgdir/usr/share/doc/$pkgname/"
- install -Dm644 tutorial.md "$pkgdir/usr/share/doc/$pkgname/tutorial.md"
+ install -Dm644 TUTORIAL.md "$pkgdir/usr/share/doc/$pkgname/TUTORIAL.md"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
-
-# vim:set ts=2 sw=2 et: