summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD25
3 files changed, 17 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index afc3428de60f..e1c9a91ba7f2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = bazelisk-bin
pkgdesc = A user-friendly launcher for Bazel
- pkgver = 1.8.1
- pkgrel = 2
+ pkgver = 1.7.4
+ pkgrel = 1
url = https://github.com/bazelbuild/bazelisk
arch = x86_64
- license = Apache
+ license = Apache 2.0
provides = bazel
conflicts = bazel
- source = LICENSE-1.8.1::https://raw.githubusercontent.com/bazelbuild/bazelisk/v1.8.1/LICENSE
- source = bazelisk-linux-amd64-1.8.1::https://github.com/bazelbuild/bazelisk/releases/download/v1.8.1/bazelisk-linux-amd64
+ source = https://raw.githubusercontent.com/bazelbuild/bazelisk/v1.7.4/LICENSE
+ source = bazelisk-linux-amd64-1.7.4::https://github.com/bazelbuild/bazelisk/releases/download/v1.7.4/bazelisk-linux-amd64
sha256sums = c71d239df91726fc519c6eb72d318ec65820627232b2f796219e87dcf35d0ab4
- sha256sums = 4a7652ffe904ccb064aaa7db41c456e742e507e574f58a602edbbc32920ed79b
+ sha256sums = ab258203db518a54cbd5afa80864d5a3bb366058b95e7a7df4134b0b7765a378
pkgname = bazelisk-bin
diff --git a/.gitignore b/.gitignore
index 323d9c76bec4..4401535d1f88 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,2 +1,2 @@
-LICENSE-*
+LICENSE
bazelisk-linux-amd64*
diff --git a/PKGBUILD b/PKGBUILD
index f92937a87ca0..6f92699b563f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,22 @@
# Maintainer: Benjamin Denhartog <ben@sudoforge.com>
pkgname=bazelisk-bin
-pkgver=1.8.1
-pkgrel=2
-pkgdesc='A user-friendly launcher for Bazel'
-url='https://github.com/bazelbuild/bazelisk'
-conflicts=("bazel")
+pkgver=1.7.4
+pkgrel=1
+pkgdesc="A user-friendly launcher for Bazel"
+url="https://github.com/bazelbuild/bazelisk"
+conflicts=('bazel')
provides=('bazel')
-license=('Apache')
+license=('Apache 2.0')
arch=('x86_64')
source=(
- "LICENSE-${pkgver}::https://raw.githubusercontent.com/bazelbuild/bazelisk/v${pkgver}/LICENSE"
+ "https://raw.githubusercontent.com/bazelbuild/bazelisk/v${pkgver}/LICENSE"
"bazelisk-linux-amd64-${pkgver}::https://github.com/bazelbuild/bazelisk/releases/download/v${pkgver}/bazelisk-linux-amd64"
)
sha256sums=('c71d239df91726fc519c6eb72d318ec65820627232b2f796219e87dcf35d0ab4'
- '4a7652ffe904ccb064aaa7db41c456e742e507e574f58a602edbbc32920ed79b')
+ 'ab258203db518a54cbd5afa80864d5a3bb366058b95e7a7df4134b0b7765a378')
package() {
- install -D -m 644 \
- "${srcdir}/${source[0]%%::*}" \
- "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-
- install -D -m 755 \
- "${srcdir}/${source[1]%%::*}" \
- "${pkgdir}/usr/bin/${pkgname%isk-bin}"
+ install -D -m 644 "${srcdir}/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -D -m 755 "${srcdir}/${source[1]%%::*}" "${pkgdir}/usr/bin/${pkgname%isk-bin}"
}