summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD3
-rw-r--r--crc64.patch11
2 files changed, 14 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e9dac05e4555..eb085484e42b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,8 +17,10 @@ provides=('bcache-tools')
conflicts=('bcache-tools')
install="${pkgname}.install"
source=("git+https://github.com/g2p/${_gitname}.git"
+ 'crc64.patch'
'initcpio-arch.patch')
md5sums=('SKIP'
+ '265f3d6ad0bd1596eac8a2c3512f2d87'
'208d7024340b8db3cf21325df40b6267')
# set _gitrev to a git revision (man gitrevisions) like a tag, a commit sha1
@@ -36,6 +38,7 @@ pkgver() {
prepare() {
cd "${srcdir}/${_gitname}"
patch -Np1 -i "${srcdir}/initcpio-arch.patch"
+ patch -Np1 -i "${srcdir}/crc64.patch"
}
build() {
diff --git a/crc64.patch b/crc64.patch
new file mode 100644
index 000000000000..511c376f3e95
--- /dev/null
+++ b/crc64.patch
@@ -0,0 +1,11 @@
+--- a/bcache.c
++++ b/bcache.c
+@@ -115,7 +115,7 @@ static const uint64_t crc_table[256] = {
+ 0x9AFCE626CE85B507ULL
+ };
+
+-inline uint64_t crc64(const void *_data, size_t len)
++uint64_t crc64(const void *_data, size_t len)
+ {
+ uint64_t crc = 0xFFFFFFFFFFFFFFFFULL;
+ const unsigned char *data = _data;