summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO31
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD66
-rw-r--r--add-mkinitcpio-hook-for-Arch.patch4
-rw-r--r--bcachefs-tools-git.install8
5 files changed, 71 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7ca48d3aff00..0ee121050e0b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,15 @@
pkgbase = bcachefs-tools-git
pkgdesc = BCacheFS filesystem utilities
- pkgver = 448
+ pkgver = 1339
pkgrel = 1
url = https://github.com/koverstreet/bcachefs-tools
install = bcachefs-tools-git.install
arch = x86_64
license = GPL2
makedepends = attr
+ makedepends = cargo
+ makedepends = clang
+ makedepends = fuse3
makedepends = git
makedepends = keyutils
makedepends = libaio
@@ -15,12 +18,32 @@ pkgbase = bcachefs-tools-git
makedepends = liburcu
makedepends = libutil-linux
makedepends = pkgconf
+ makedepends = python-docutils
+ makedepends = systemd
+ makedepends = valgrind
makedepends = zlib
+ depends = attr
+ depends = cargo
+ depends = clang
+ depends = fuse3
+ depends = git
+ depends = keyutils
+ depends = libaio
+ depends = libscrypt
+ depends = libsodium
+ depends = liburcu
+ depends = libutil-linux
+ depends = pkgconf
+ depends = python-docutils
+ depends = systemd
+ depends = valgrind
+ depends = zlib
provides = bcachefs-tools
+ conflicts = bcachefs-tools
+ options = !strip
source = git+https://github.com/koverstreet/bcachefs-tools
source = add-mkinitcpio-hook-for-Arch.patch
- sha256sums = SKIP
- sha256sums = b4d6bc483b417ceaa5c628c686a613e568e64a699288da0388d508a481c710e9
+ sha512sums = SKIP
+ sha512sums = 5ebb0c6b17e7a61ccd2c157a0a833bc51e1d66cdf9711c8038c9e695ba22bf4098695658401bef9560ec02722787de0d89e1ccf7b8a716f9eeb136ad2e59daca
pkgname = bcachefs-tools-git
-
diff --git a/.gitignore b/.gitignore
index 7a59fae073ea..bdc1cdf56a77 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1 +1,6 @@
-bcachefs-tools \ No newline at end of file
+bcachefs-tools
+*.xz
+*.gz
+*.pkg.tar*
+pkg
+src \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 6f3ed00aa855..001f6b376be0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,61 +1,59 @@
# Maintainer: Kyle De'Vir (QuartzDragon) <kyle.devir.mykolab.com>
pkgname=bcachefs-tools-git
-pkgver=448
+pkgver=1339
pkgrel=1
pkgdesc="BCacheFS filesystem utilities"
url="https://github.com/koverstreet/bcachefs-tools"
arch=("x86_64")
license=("GPL2")
-install="${pkgname}.install"
-
-provides=("bcachefs-tools")
-makedepends=(
- "attr"
- "git"
- "keyutils"
- "libaio"
- "libscrypt"
- "libsodium"
- "liburcu"
- "libutil-linux"
- "pkgconf"
- "zlib"
-)
+install="$pkgname.install"
+
+provides=(bcachefs-tools)
+conflicts=(bcachefs-tools)
+dependsarray="attr cargo clang fuse3 git keyutils libaio libscrypt libsodium liburcu libutil-linux pkgconf python-docutils systemd valgrind zlib"
+makedepends=(${dependsarray})
+depends=(${dependsarray})
+
+options=('!strip')
_reponame="bcachefs-tools"
-_repo_url="https://github.com/koverstreet/${_reponame}"
+_repo_url="https://github.com/koverstreet/$_reponame"
-source=("git+${_repo_url}"
- "add-mkinitcpio-hook-for-Arch.patch")
-sha256sums=('SKIP'
- 'b4d6bc483b417ceaa5c628c686a613e568e64a699288da0388d508a481c710e9')
+source=(
+ "git+$_repo_url"
+ "add-mkinitcpio-hook-for-Arch.patch"
+)
+sha512sums=('SKIP'
+ '5ebb0c6b17e7a61ccd2c157a0a833bc51e1d66cdf9711c8038c9e695ba22bf4098695658401bef9560ec02722787de0d89e1ccf7b8a716f9eeb136ad2e59daca')
-pkgver() {
- cd "${srcdir}/${_reponame}"
+prepare() {
+ cd "$srcdir/$_reponame"
- echo "$(git rev-list --count HEAD)"
+ PName="add-mkinitcpio-hook-for-Arch.patch"
+ msg2 "Patching with $PName ..."
+ patch -Np1 -i "../$PName"
}
-prepare() {
- cd "${srcdir}/${_reponame}"
-
- patch -Np1 -i "../add-mkinitcpio-hook-for-Arch.patch"
+pkgver() {
+ cd "$srcdir/$_reponame"
+
+ echo "$(git rev-list --count HEAD)"
}
build() {
- cd "${srcdir}/${_reponame}"
+ cd "$srcdir/$_reponame"
make
}
package() {
- cd "${srcdir}/${_reponame}"
+ cd "$srcdir/$_reponame"
+
+ make DESTDIR="$pkgdir" PREFIX="/usr" ROOT_SBINDIR="/usr/bin" INITRAMFS_DIR="/etc/initcpio" install
- make DESTDIR="${pkgdir}" PREFIX="/usr" ROOT_SBINDIR="/usr/bin" INITRAMFS_DIR="/etc/initcpio" install
-
install -Dm644 "arch/etc/initcpio/hooks/bcachefs" \
- "${pkgdir}/etc/initcpio/hooks/bcachefs"
+ "$pkgdir/etc/initcpio/hooks/bcachefs"
install -Dm644 "arch/etc/initcpio/install/bcachefs" \
- "${pkgdir}/etc/initcpio/install/bcachefs"
+ "$pkgdir/etc/initcpio/install/bcachefs"
}
diff --git a/add-mkinitcpio-hook-for-Arch.patch b/add-mkinitcpio-hook-for-Arch.patch
index a930780763fe..5e06647994cf 100644
--- a/add-mkinitcpio-hook-for-Arch.patch
+++ b/add-mkinitcpio-hook-for-Arch.patch
@@ -18,7 +18,7 @@ index 0000000..cc2ed7e
--- /dev/null
+++ b/arch/etc/initcpio/hooks/bcachefs
@@ -0,0 +1,14 @@
-+#!/usr/bin/ash
++#!/usr/bin/bash
+
+run_hook() {
+
@@ -41,7 +41,7 @@ index 0000000..67ce186
+#!/bin/bash
+
+build() {
-+ add_module `bcachefs`
++ add_module "bcachefs"
+ add_binary "bcachefs"
+
+ add_runscript
diff --git a/bcachefs-tools-git.install b/bcachefs-tools-git.install
index f9ac55335bfc..6baeb4ae7185 100644
--- a/bcachefs-tools-git.install
+++ b/bcachefs-tools-git.install
@@ -1,16 +1,16 @@
post_upgrade() {
- echo "If you haven't already, please manually add 'bcachefs' to mkinitcpio.conf variables 'MODULES=()', 'BINARIES=()', and 'HOOKS=()'"
+ echo "If you haven't already, please manually add 'bcachefs' to mkinitcpio.conf variables 'MODULES=()' and 'HOOKS=()', and also add '/usr/bin/bcachefs' to 'BINARIES=()'"
echo "and then run 'mkinitcpio -p linux-bcachefs-git'"
}
post_install() {
- echo "Please manually add 'bcachefs' to mkinitcpio.conf variables 'MODULES=()', 'BINARIES=()', and 'HOOKS=()'"
+ echo "Please manually add 'bcachefs' to mkinitcpio.conf variables 'MODULES=()' and 'HOOKS=()', and also add '/usr/bin/bcachefs' to 'BINARIES=()'"
echo "and then run 'mkinitcpio -p linux-bcachefs-git'"
}
post_remove() {
- echo "Please manually remove 'bcachefs' to mkinitcpio.conf variables 'MODULES=()', 'BINARIES=()', and 'HOOKS=()'"
+ echo "Please manually remove 'bcachefs' from mkinitcpio.conf variables 'MODULES=()' and 'HOOKS=()', and also remove '/usr/bin/bcachefs' from 'BINARIES=()'"
echo "and then run 'mkinitcpio -p linux-bcachefs-git'"
}
-# vim:set ft=sh ts=8 sts=2 sw=2 et:
+# vim:set ft=sh ts=8 sts=2 sw=2 et: \ No newline at end of file