summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD22
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2ad5fc1bacf5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Tue Oct 4 20:46:38 UTC 2016
+pkgbase = bcal
+ pkgdesc = Byte CALculator. The engineer's utility for storage conversions and calculations.
+ pkgver = 35.68f5bba
+ pkgrel = 1
+ url = https://github.com/jarun/bcal
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ provides = bcal
+ conflicts = bcal
+ source = bcal::git+https://github.com/jarun/bcal.git
+ sha256sums = SKIP
+
+pkgname = bcal
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9603e7cb6cb4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: John Jenkins <twodopeshaggy@gmail.com>
+
+pkgname=bcal
+pkgver=35.68f5bba
+pkgrel=1
+pkgdesc="Byte CALculator. The engineer's utility for storage conversions and calculations."
+arch=("i686" "x86_64")
+url="https://github.com/jarun/bcal"
+license=('GPL3')
+source=(${pkgname}::"git+https://github.com/jarun/${pkgname}.git")
+sha256sums=('SKIP')
+conflicts=('bcal')
+provides=('bcal')
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ echo "$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+package() {
+ make -C "${srcdir}/${pkgname}" DESTDIR="${pkgdir}" PREFIX="/usr" install
+}