summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD156
2 files changed, 89 insertions, 87 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 65c69d959e2e..8fb58c4777d4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
-# Generated by mksrcinfo v8
-# Sat Jul 9 14:56:34 UTC 2016
pkgbase = bcc-git
pkgdesc = BPF Compiler Collection - latest git code
- pkgver = v0.1.8.r330.52cd371
+ pkgver = v0.5.0.r305.7c27c271
pkgrel = 1
url = https://github.com/iovisor/bcc
arch = x86_64
license = Apache
+ checkdepends = netperf
+ checkdepends = iperf
makedepends = cmake
makedepends = clang>=3.7.0
makedepends = llvm>=3.7.0
@@ -19,31 +19,31 @@ pkgbase = bcc-git
sha256sums = SKIP
pkgname = bcc-git
- pkgdesc = BPF Compiler Collection - C library and examples
+ pkgdesc = BPF Compiler Collection - C library and examples - latest git code
depends = linux-headers
optdepends = bcc-tools-git: Python utilites using the BCC library
optdepends = python-bcc-git: Python 3 bindings for BCC
optdepends = python2-bcc-git: Python 2 bindings for BCC
provides = bcc-git
provides = libbcc-git
- conflicts = bcc
pkgname = bcc-tools-git
- pkgdesc = BPF Compiler Collection - Tools
+ pkgdesc = BPF Compiler Collection - Tools - latest git code
+ arch = any
depends = bcc-git
optdepends = python-bcc-git: Python 3 bindings for BCC
optdepends = python2-bcc-git: Python 2 bindings for BCC
conflicts = bcc-tools
pkgname = python-bcc-git
- pkgdesc = BPF Compiler Collection - Python 3 bindings
+ pkgdesc = BPF Compiler Collection - Python 3 bindings - latest git code
+ arch = any
depends = bcc-git
depends = python
- conflicts = python-bcc
pkgname = python2-bcc-git
- pkgdesc = BPF Compiler Collection - Python 2 bindings
+ pkgdesc = BPF Compiler Collection - Python 2 bindings - latest git code
+ arch = any
depends = bcc-git
depends = python2
- conflicts = python2-bcc
diff --git a/PKGBUILD b/PKGBUILD
index 253b7527b94f..83a050622cf4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,18 @@
-# Maintainer: Troy Engel <troyengel+arch@gmail.com>
+# Maintainer: Omar Sandoval <osandov@osandov.com>
+# Contributor: Troy Engel <troyengel+arch@gmail.com>
# Contributor: Manuel Mendez <mmendez534@gmail.com>
pkgbase=bcc-git
pkgname=('bcc-git' 'bcc-tools-git' 'python-bcc-git' 'python2-bcc-git')
-pkgver=v0.1.8.r330.52cd371
+pkgver=v0.5.0.r305.7c27c271
pkgrel=1
-pkgdesc="BPF Compiler Collection - latest git code"
+pkgdesc='BPF Compiler Collection - latest git code'
arch=('x86_64')
-url="https://github.com/iovisor/bcc"
+url='https://github.com/iovisor/bcc'
license=('Apache')
conflicts=('bcc')
-makedepends=('cmake' 'clang>=3.7.0' 'llvm>=3.7.0' 'flex' 'bison' 'python'
- 'python2')
+makedepends=('cmake' 'clang>=3.7.0' 'llvm>=3.7.0' 'flex' 'bison' 'python' 'python2')
+checkdepends=('netperf' 'iperf')
source=('bcc-git::git+https://github.com/iovisor/bcc')
sha256sums=('SKIP')
@@ -21,88 +22,89 @@ pkgver() {
}
build() {
- # make sure repetitive builds are clean
- [[ -d "${srcdir}/${pkgbase}/build" ]] && \
- rm -rf "${srcdir}/${pkgbase}/build"
- mkdir "${srcdir}/${pkgbase}/build"
- cd "${srcdir}/${pkgbase}/build"
-
- # we don't care which python here for the core C library
- cmake .. \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=/usr/lib
- make
+ cd "${srcdir}/${pkgbase}"
+ rm -rf build
+ mkdir build
+ cd build
+
+ # The python version is irrelevant at this stage
+ cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=/usr/lib ..
+
+ make
}
package_bcc-git() {
- pkgdesc="BPF Compiler Collection - C library and examples"
- makedepends=('cmake' 'clang>=3.7.0' 'llvm>=3.7.0' 'flex' 'bison')
- provides=('bcc-git' 'libbcc-git')
- conflicts=('bcc')
- depends=('linux-headers')
- optdepends=('bcc-tools-git: Python utilites using the BCC library'
- 'python-bcc-git: Python 3 bindings for BCC'
- 'python2-bcc-git: Python 2 bindings for BCC')
-
- # this installs the kitchen sink
- cd "${srcdir}/${pkgbase}/build"
- make DESTDIR="${pkgdir}/" install
-
- # these go in a split package python*-bcc
- rm -rf "${pkgdir}"/usr/lib/python*
-
- # these go in a split package bcc-tools
- rm -rf "${pkgdir}"/usr/share/bcc/{tools,man}
-}
+ pkgdesc='BPF Compiler Collection - C library and examples - latest git code'
+ depends=('linux-headers')
+ optdepends=('bcc-tools-git: Python utilites using the BCC library'
+ 'python-bcc-git: Python 3 bindings for BCC'
+ 'python2-bcc-git: Python 2 bindings for BCC')
+ makedepends=('cmake' 'clang>=3.7.0' 'llvm>=3.7.0' 'flex' 'bison')
+ provides=('bcc-git' 'libbcc-git')
-package_bcc-tools-git() {
- pkgdesc="BPF Compiler Collection - Tools"
- depends=('bcc-git')
- conflicts=('bcc-tools')
- optdepends=('python-bcc-git: Python 3 bindings for BCC'
- 'python2-bcc-git: Python 2 bindings for BCC')
+ cd "${srcdir}/${pkgbase}/build"
- cd "${srcdir}/${pkgbase}/build/tools"
- make DESTDIR="${pkgdir}/" install
+ # Install the kitchen sink
+ make DESTDIR="${pkgdir}" install
- cd "${srcdir}/${pkgbase}/build/man"
- make DESTDIR="${pkgdir}/" install
+ # These go in a split package python*-bcc-git
+ rm -rf "${pkgdir}"/usr/lib/python*
+ # These go in a split package bcc-tools-git
+ rm -rf "${pkgdir}"/usr/share/bcc/{tools,man}
+}
+
+package_bcc-tools-git() {
+ pkgdesc='BPF Compiler Collection - Tools - latest git code'
+ arch=('any')
+ depends=('bcc-git')
+ conflicts=('bcc-tools')
+ optdepends=('python-bcc-git: Python 3 bindings for BCC'
+ 'python2-bcc-git: Python 2 bindings for BCC')
+
+ cd "${srcdir}/${pkgbase}/build/tools"
+ make DESTDIR="${pkgdir}" install
+
+ cd "${srcdir}/${pkgbase}/build/man"
+ make DESTDIR="${pkgdir}" install
}
package_python-bcc-git() {
- pkgdesc="BPF Compiler Collection - Python 3 bindings"
- makedepends=('cmake')
- depends=('bcc-git' 'python')
- conflicts=('python-bcc')
-
- # the C lib s already built, force a quick python3 binding build
- cd "${srcdir}/${pkgbase}/build"
- cmake .. -DPYTHON_CMD="python" \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=/usr/lib
- make
-
- # now install just those bindings
- cd "${srcdir}/${pkgbase}/build/src/python"
- make DESTDIR="${pkgdir}/" install
+ pkgdesc='BPF Compiler Collection - Python 3 bindings - latest git code'
+ arch=('any')
+ depends=('bcc-git' 'python')
+ makedepends=('cmake')
+
+ cd "${srcdir}/${pkgbase}/build"
+
+ # Force a quick python3 binding build (C library is already buidl)
+ cmake -DREVISION="${pkgver}" \
+ -DPYTHON_CMD="python" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=/usr/lib ..
+
+ make
+
+ # Install just those bindings
+ make -C "${srcdir}/${pkgbase}/build/src/python" DESTDIR="${pkgdir}" install
}
package_python2-bcc-git() {
- pkgdesc="BPF Compiler Collection - Python 2 bindings"
- makedepends=('cmake')
- depends=('bcc-git' 'python2')
- conflicts=('python2-bcc')
-
- # the C lib is already built, force a quick python2 binding build
- cd "${srcdir}/${pkgbase}/build"
- cmake .. -DPYTHON_CMD="python2" \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=/usr/lib
- make
-
- # now install just those bindings
- cd "${srcdir}/${pkgbase}/build/src/python"
- make DESTDIR="${pkgdir}/" install
-}
+ pkgdesc='BPF Compiler Collection - Python 2 bindings - latest git code'
+ arch=('any')
+ depends=('bcc-git' 'python2')
+ makedepends=('cmake')
+ cd "${srcdir}/${pkgbase}/build"
+
+ # Force a quick python2 binding build (C library is already buidl)
+ cmake -DPYTHON_CMD="python2" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=/usr/lib ..
+
+ make
+
+ # Install just those bindings
+ make -C "${srcdir}/${pkgbase}/build/src/python" DESTDIR="${pkgdir}" install
+}