summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD24
-rw-r--r--makefile-system-htslib.patch87
3 files changed, 17 insertions, 104 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ecebbdc8bf17..09ebedbd8910 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun May 14 21:02:41 UTC 2017
+# Wed Jun 28 15:26:46 UTC 2017
pkgbase = bcftools
pkgdesc = Reading/writing BCF2/VCF/gVCF files and calling/filtering/summarising SNP and short indel sequence variants
- pkgver = 1.4.1
+ pkgver = 1.5
pkgrel = 1
url = http://samtools.github.io/bcftools/
arch = i686
@@ -11,10 +11,8 @@ pkgbase = bcftools
depends = gsl
depends = htslib
optdepends = python2: needed for some scripts
- source = https://github.com/samtools/bcftools/releases/download/1.4.1/bcftools-1.4.1.tar.bz2
- source = makefile-system-htslib.patch
- md5sums = 103729569ca3e265b13d2fed5775016e
- md5sums = 1777e7d3bcfd428de407f62c870904cb
+ source = https://github.com/samtools/bcftools/releases/download/1.5/bcftools-1.5.tar.bz2
+ md5sums = e43efe3df5f9c55acb4b48cee214d281
pkgname = bcftools
diff --git a/PKGBUILD b/PKGBUILD
index 3b311bcd3714..bb2e905bb39d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Christian Krause ("wookietreiber") <christian.krause@mailbox.org>
pkgname=bcftools
-pkgver=1.4.1
+pkgver=1.5
pkgrel=1
pkgdesc="Reading/writing BCF2/VCF/gVCF files and calling/filtering/summarising SNP and short indel sequence variants"
arch=('i686' 'x86_64')
@@ -9,8 +9,7 @@ url="http://samtools.github.io/bcftools/"
license=('GPL')
depends=('gsl' 'htslib')
optdepends=('python2: needed for some scripts')
-source=(https://github.com/samtools/bcftools/releases/download/$pkgver/$pkgname-$pkgver.tar.bz2
- makefile-system-htslib.patch)
+source=(https://github.com/samtools/bcftools/releases/download/$pkgver/$pkgname-$pkgver.tar.bz2)
prepare() {
cd $srcdir/$pkgname-$pkgver
@@ -21,28 +20,31 @@ prepare() {
sed -e 's|#!/usr/bin/env python|#!/usr/bin/env python2|' \
-e 's|#!/usr/bin/python|#!/usr/bin/env python2|' \
-i misc/plot-roh.py misc/guess-ploidy.py
-
- # patch Makefile to make it work with a system-provided htslib
- patch -i $srcdir/makefile-system-htslib.patch
}
build() {
cd $srcdir/$pkgname-$pkgver
- make prefix=/usr plugindir=/usr/lib/$pkgname USE_GPL=1
+ ./configure \
+ --prefix=/usr \
+ --enable-libgsl \
+ --with-bcf-plugin-dir=/usr/lib/$pkgname \
+ --with-cblas=gslcblas \
+ --with-htslib=system
+
+ make
}
check() {
cd $srcdir/$pkgname-$pkgver
- make prefix=/usr plugindir=/usr/lib/$pkgname USE_GPL=1 test
+ make check
}
package() {
cd $srcdir/$pkgname-$pkgver
- make prefix=/usr plugindir=/usr/lib/$pkgname USE_GPL=1 DESTDIR=$pkgdir install
+ make DESTDIR=$pkgdir install
}
-md5sums=('103729569ca3e265b13d2fed5775016e'
- '1777e7d3bcfd428de407f62c870904cb')
+md5sums=('e43efe3df5f9c55acb4b48cee214d281')
diff --git a/makefile-system-htslib.patch b/makefile-system-htslib.patch
deleted file mode 100644
index 7e98ae5d9f98..000000000000
--- a/makefile-system-htslib.patch
+++ /dev/null
@@ -1,87 +0,0 @@
---- Makefile.orig 2017-03-14 07:26:49.191430557 +0100
-+++ Makefile 2017-03-14 07:27:44.929678345 +0100
-@@ -29,20 +29,10 @@
- all: $(PROG) $(TEST_PROG)
-
- # Adjust $(HTSDIR) to point to your top-level htslib directory
--HTSDIR = htslib-1.4.1
--include $(HTSDIR)/htslib.mk
--include $(HTSDIR)/htslib_static.mk
--HTSLIB = $(HTSDIR)/libhts.a
--BGZIP = $(HTSDIR)/bgzip
--TABIX = $(HTSDIR)/tabix
--HTSLIB_LDFLAGS = $(HTSLIB_static_LDFLAGS)
--HTSLIB_LIBS = $(HTSLIB_static_LIBS)
-+HTSDIR = /usr/include
-
- CC = gcc
--CPPFLAGS =
--CFLAGS = -g -Wall -Wc++-compat -O2
--LDFLAGS =
--LIBS =
-+CFLAGS := -g -Wall -Wc++-compat -O2 $(CFLAGS)
-
- ifeq "$(shell uname -s)" "Darwin"
- DYNAMIC_FLAGS = -Wl,-export_dynamic
-@@ -51,8 +41,8 @@
- endif
-
- # TODO Use configure or htslib.pc to add -rdynamic/-ldl conditionally
--ALL_CPPFLAGS = -I. $(HTSLIB_CPPFLAGS) $(CPPFLAGS)
--ALL_LDFLAGS = $(DYNAMIC_FLAGS) $(HTSLIB_LDFLAGS) $(LDFLAGS)
-+ALL_CPPFLAGS = -I. $(CPPFLAGS)
-+ALL_LDFLAGS = $(DYNAMIC_FLAGS) $(LDFLAGS)
- ALL_LIBS = -lm -lz -ldl $(LIBS)
-
- OBJS = main.o vcfindex.o tabix.o \
-@@ -64,7 +54,7 @@
- mpileup.o bam2bcf.o bam2bcf_indel.o bam_sample.o \
- ccall.o em.o prob1.o kmin.o # the original samtools calling
-
--EXTRA_CPPFLAGS = -I. -I$(HTSDIR) -DPLUGINPATH=\"$(pluginpath)\"
-+EXTRA_CPPFLAGS = -I. -DPLUGINPATH=\"$(pluginpath)\"
- GSL_LIBS =
-
- # The polysomy command is not compiled by default because it brings dependency
-@@ -73,7 +63,7 @@
- ifdef USE_GPL
- EXTRA_CPPFLAGS += -DUSE_GPL
- OBJS += polysomy.o peakfit.o
-- GSL_LIBS = -lgsl -lcblas
-+ GSL_LIBS = -lgsl -lgslcblas
- endif
-
- prefix = /usr/local
-@@ -117,12 +107,12 @@
- .c.o:
- $(CC) $(CFLAGS) $(EXTRA_CPPFLAGS) $(ALL_CPPFLAGS) -c -o $@ $<
-
--test: $(PROG) plugins test/test-rbuf test/test-regidx $(BGZIP) $(TABIX)
-+test: $(PROG) plugins test/test-rbuf test/test-regidx
- ./test/test-regidx
-- ./test/test.pl --exec bgzip=$(BGZIP) --exec tabix=$(TABIX)
-+ ./test/test.pl --exec bgzip=bgzip --exec tabix=tabix
-
--test-plugins: $(PROG) plugins test/test-rbuf $(BGZIP) $(TABIX)
-- ./test/test.pl --plugins --exec bgzip=$(BGZIP) --exec tabix=$(TABIX)
-+test-plugins: $(PROG) plugins test/test-rbuf
-+ ./test/test.pl --plugins --exec bgzip=bgzip --exec tabix=tabix
-
-
- # Plugin rules
-@@ -208,11 +198,11 @@
-
- test/test-regidx.o: test/test-regidx.c regidx.h
-
--test/test-regidx: test/test-regidx.o regidx.o $(HTSLIB)
-- $(CC) $(ALL_LDFLAGS) -o $@ $^ $(HTSLIB) -lpthread $(HTSLIB_LIBS) $(ALL_LIBS)
-+test/test-regidx: test/test-regidx.o regidx.o
-+ $(CC) $(ALL_LDFLAGS) -o $@ $^ -lpthread -lhts $(ALL_LIBS)
-
--bcftools: $(HTSLIB) $(OBJS)
-- $(CC) $(ALL_LDFLAGS) -o $@ $(OBJS) $(HTSLIB) -lpthread $(HTSLIB_LIBS) $(GSL_LIBS) $(ALL_LIBS)
-+bcftools: $(OBJS)
-+ $(CC) $(ALL_LDFLAGS) -o $@ $(OBJS) -lpthread -lhts $(GSL_LIBS) $(ALL_LIBS)
-
- doc/bcftools.1: doc/bcftools.txt
- cd doc && a2x -adate="$(DOC_DATE)" -aversion=$(DOC_VERSION) --doctype manpage --format manpage bcftools.txt