summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 02ef6c0596a4..2ad9b48277a5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = bcm20702a1-firmware
- pkgdesc = Firmware for BCM20702A1 based devices (0b05:17cb, 0b05:17cf, 0a5c:21e1 and 0a5c:21e6)
+ pkgdesc = Firmware for BCM20702A1 based devices (0b05:17cb, 0b05:17cf, 0a5c:21e1, 0a5c:21e6, 0a5c:21e8)
pkgver = 1201650
- pkgrel = 3
+ pkgrel = 4
url = http://asus.com
arch = any
license = Custom
makedepends = bluez-utils
source = http://dlcdnet.asus.com/pub/ASUS/misc/BT/Bluetooth_V1201650_WHQL_Win10.zip
+ source = BCM20702A1-0a5c-21e8.hcd::https://s3.amazonaws.com/plugable/bin/fw-0a5c_21e8.hcd
sha256sums = b8863fdb2f397c1ca7264fd4a0f457c2f9ab90350338e476128fb241720e32ad
+ sha256sums = d699c13fe1e20c068a8a88dbbed49edc12527b0ceeeaac3411e3298573451536
pkgname = bcm20702a1-firmware
diff --git a/PKGBUILD b/PKGBUILD
index ed5e58b39f0e..1b58c65ea2e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,16 @@
pkgname=bcm20702a1-firmware
pkgver=1201650
-pkgrel=3
-pkgdesc="Firmware for BCM20702A1 based devices (0b05:17cb, 0b05:17cf, 0a5c:21e1 and 0a5c:21e6)"
+pkgrel=4
+pkgdesc="Firmware for BCM20702A1 based devices (0b05:17cb, 0b05:17cf, 0a5c:21e1, 0a5c:21e6, 0a5c:21e8)"
arch=('any')
url="http://asus.com"
license=("Custom")
makedepends=('bluez-utils')
-source=("http://dlcdnet.asus.com/pub/ASUS/misc/BT/Bluetooth_V${pkgver}_WHQL_Win10.zip")
-sha256sums=('b8863fdb2f397c1ca7264fd4a0f457c2f9ab90350338e476128fb241720e32ad')
+source=("http://dlcdnet.asus.com/pub/ASUS/misc/BT/Bluetooth_V${pkgver}_WHQL_Win10.zip"
+ "BCM20702A1-0a5c-21e8.hcd::https://s3.amazonaws.com/plugable/bin/fw-0a5c_21e8.hcd")
+sha256sums=('b8863fdb2f397c1ca7264fd4a0f457c2f9ab90350338e476128fb241720e32ad'
+ 'd699c13fe1e20c068a8a88dbbed49edc12527b0ceeeaac3411e3298573451536')
build() {
hex2hcd "$srcdir/Bluetooth/BCM_DriverOnly/64/BCM20702A1_001.002.014.1443.1467.hex" -o "${srcdir}/BCM20702A1-0b05-17cb.hcd"
@@ -26,5 +28,6 @@ package() {
install -m644 "${srcdir}/BCM20702A1-0b05-17cf.hcd" "${pkgdir}/usr/lib/firmware/brcm/BCM20702A1-0b05-17cf.hcd"
install -m644 "${srcdir}/BCM20702A0-0a5c-21e1.hcd" "${pkgdir}/usr/lib/firmware/brcm/BCM20702A0-0a5c-21e1.hcd"
install -m644 "${srcdir}/BCM20702A1-0a5c-21e6.hcd" "${pkgdir}/usr/lib/firmware/brcm/BCM20702A1-0a5c-21e6.hcd"
+ install -m644 "${srcdir}/BCM20702A1-0a5c-21e8.hcd" "${pkgdir}/usr/lib/firmware/brcm/BCM20702A1-0a5c-21e8.hcd"
}