summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD22
2 files changed, 19 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fb3756346684..3a1fa7f50e9c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
+# Generated by mksrcinfo v8
+# Sat Jan 16 14:54:39 UTC 2016
pkgbase = bcm20702a1-firmware
- pkgdesc = Firmware for BCM20702A1 based ASUS X99 USB bluetooth devices (0b05:17cf)
- pkgver = 1201550
- pkgrel = 3
- url = http://linuxtv.org/wiki/index.php/Afatech_AF9005
+ pkgdesc = Firmware for BCM20702A1 based devices (0b05:17cb and 0b05:17cf)
+ pkgver = 1201650
+ pkgrel = 1
+ url = http://asus.com
arch = any
license = Custom
makedepends = bluez-utils
- provides = linux-firmware
- source = http://dlm3cdnet.asus.com/pub/ASUS/misc/BT/Bluetooth_V1201550_Win10.zip
- sha256sums = fe1efb02a5779f67ffecce79d44622e7e2795a9b31352e0f490f63bb471a78d1
+ source = http://dlcdnet.asus.com/pub/ASUS/misc/BT/Bluetooth_V1201650_WHQL_Win10.zip
+ sha256sums = b8863fdb2f397c1ca7264fd4a0f457c2f9ab90350338e476128fb241720e32ad
pkgname = bcm20702a1-firmware
diff --git a/PKGBUILD b/PKGBUILD
index c6e2d75c2e2a..3305f8d86d8f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,25 @@
# Maintainer: Sonic-Y3k <sonic.y3k@googlemail.com>
+# Contributor: Christopher Reimer <mail+aur[at]c-reimer[dot]de>
pkgname=bcm20702a1-firmware
-pkgver=1201550
-pkgrel=3
-pkgdesc="Firmware for BCM20702A1 based ASUS X99 USB bluetooth devices (0b05:17cf)"
-arch=(any)
-url="http://linuxtv.org/wiki/index.php/Afatech_AF9005"
+pkgver=1201650
+pkgrel=1
+pkgdesc="Firmware for BCM20702A1 based devices (0b05:17cb and 0b05:17cf)"
+arch=('any')
+url="http://asus.com"
license=("Custom")
makedepends=('bluez-utils')
-source=("http://dlm3cdnet.asus.com/pub/ASUS/misc/BT/Bluetooth_V${pkgver}_Win10.zip")
-sha256sums=('fe1efb02a5779f67ffecce79d44622e7e2795a9b31352e0f490f63bb471a78d1')
-provides=('linux-firmware')
+source=("http://dlcdnet.asus.com/pub/ASUS/misc/BT/Bluetooth_V${pkgver}_WHQL_Win10.zip")
+sha256sums=('b8863fdb2f397c1ca7264fd4a0f457c2f9ab90350338e476128fb241720e32ad')
build() {
- cd "${srcdir}"
- cp "${srcdir}/Bluetooth_V1201550_Win10/Win32/BCM20702A1_001.002.014.1443.1469.hex" "${srcdir}/"
- hex2hcd "${srcdir}/BCM20702A1_001.002.014.1443.1469.hex" -o "${srcdir}/BCM20702A1-0b05-17cf.hcd"
+ hex2hcd "$srcdir/Bluetooth/BCM_DriverOnly/64/BCM20702A1_001.002.014.1443.1467.hex" -o "${srcdir}/BCM20702A1-0b05-17cb.hcd"
+ hex2hcd "$srcdir/Bluetooth/BCM_DriverOnly/64/BCM20702A1_001.002.014.1443.1469.hex" -o "${srcdir}/BCM20702A1-0b05-17cf.hcd"
}
package() {
mkdir -p ${pkgdir}/usr/lib/firmware/brcm
+ install -m644 "${srcdir}/BCM20702A1-0b05-17cb.hcd" "${pkgdir}/usr/lib/firmware/brcm/BCM20702A1-0b05-17cb.hcd"
install -m644 "${srcdir}/BCM20702A1-0b05-17cf.hcd" "${pkgdir}/usr/lib/firmware/brcm/BCM20702A1-0b05-17cf.hcd"
}