summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO36
-rw-r--r--.gitignore9
-rw-r--r--PKGBUILD58
-rw-r--r--bcn3dcura.patch10
4 files changed, 113 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b34ec23e59fd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,36 @@
+pkgbase = bcn3dcura-git
+ pkgdesc = 3D printer / slicing GUI forked from Cura and built on top of the Uranium framework, customized for the BCN3D machines.
+ pkgver = 2.1.5
+ pkgrel = 1
+ url = https://github.com/BCN3D/Cura
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = cmake
+ depends = python
+ depends = python-pyqt5
+ depends = python-numpy
+ depends = python-protobuf
+ depends = qt5-graphicaleffects
+ depends = qt5-quickcontrols
+ depends = qt5-quickcontrols2
+ depends = libarcus-git
+ depends = libsavitar
+ depends = bcn3duranium-git
+ depends = bcn3dcuraengine-git
+ optdepends = python-zeroconf: Detecting mDNS printers
+ optdepends = cura-binary-data-git: Firmwares and translations
+ optdepends = python-pyserial: USB printing
+ provides = cura
+ provides = bcn3dcura
+ conflicts = cura
+ conflicts = bcn3dcura
+ source = git+https://github.com/BCN3D/Cura.git
+ source = git+https://github.com/BCN3D/CuraResources.git
+ source = bcn3dcura.patch
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = 82ab7bf90b0c3529a571bbb9e8f912ae
+
+pkgname = bcn3dcura-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0f06234f4312
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+Cura
+CuraResources
+src
+pkg
+*.tar.xz
+*.tar.gz
+*.zip
+*.log
+.psci_modules
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7fc9fe5d93da
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: Adam Goldsmith <contact@adamgoldsmith.name>
+
+pkgname=bcn3dcura-git
+pkgver=2.1.5
+pkgrel=1
+pkgdesc="3D printer / slicing GUI forked from Cura and built on top of the Uranium framework, customized for the BCN3D machines."
+arch=('any')
+license=('GPL3')
+url="https://github.com/BCN3D/Cura"
+provides=('cura' 'bcn3dcura')
+conflicts=('cura' 'bcn3dcura')
+depends=('python'
+ 'python-pyqt5'
+ 'python-numpy'
+ 'python-protobuf'
+ 'qt5-graphicaleffects'
+ 'qt5-quickcontrols'
+ 'qt5-quickcontrols2'
+ 'libarcus-git'
+ 'libsavitar'
+ 'bcn3duranium-git'
+ 'bcn3dcuraengine-git')
+makedepends=('git' 'cmake')
+optdepends=('python-zeroconf: Detecting mDNS printers'
+ 'cura-binary-data-git: Firmwares and translations'
+ 'python-pyserial: USB printing')
+source=('git+https://github.com/BCN3D/Cura.git'
+ 'git+https://github.com/BCN3D/CuraResources.git'
+ 'bcn3dcura.patch')
+md5sums=('SKIP'
+ 'SKIP'
+ '82ab7bf90b0c3529a571bbb9e8f912ae')
+
+prepare() {
+ cd $srcdir
+ patch --forward --strip=1 --input="${srcdir}/bcn3dcura.patch"
+}
+
+pkgver() {
+ cd Cura
+ git describe --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ mkdir -p Cura/build
+ cd Cura/build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DURANIUM_SCRIPTS_DIR=/usr/share/uranium/scripts ..
+ make
+}
+
+package() {
+ cd "$srcdir/Cura/build"
+ make DESTDIR="$pkgdir/" install
+ cd "$srcdir/CuraResources"
+ cp -r ./. "$pkgdir/usr/share/cura/resources"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/bcn3dcura.patch b/bcn3dcura.patch
new file mode 100644
index 000000000000..1d830650f1f7
--- /dev/null
+++ b/bcn3dcura.patch
@@ -0,0 +1,10 @@
+--- src/Cura/cura_app.py 2019-11-25 19:51:02.320955181 +0100
++++ src/Cura/cura_app.py.new 2019-11-25 20:07:49.654478625 +0100
+@@ -45,7 +45,6 @@
+ #WORKAROUND: GITHUB-88 GITHUB-385 GITHUB-612
+ if Platform.isLinux(): # Needed for platform.linux_distribution, which is not available on Windows and OSX
+ # For Ubuntu: https://bugs.launchpad.net/ubuntu/+source/python-qt4/+bug/941826
+- linux_distro_name = platform.linux_distribution()[0].lower()
+ # TODO: Needs a "if X11_GFX == 'nvidia'" here. The workaround is only needed on Ubuntu+NVidia drivers. Other drivers are not affected, but fine with this fix.
+ import ctypes
+ from ctypes.util import find_library