summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD44
-rw-r--r--bcwc-pcie-dkms.install29
-rw-r--r--bcwc-pcie.modprobe.conf1
-rw-r--r--bcwc-pcie.modules-load.conf1
-rw-r--r--dkms.conf5
6 files changed, 109 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..84b3ca346dbe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+# Generated by mksrcinfo v8
+# Fri Feb 26 06:21:01 UTC 2016
+pkgbase = bcwc-pcie-dkms
+ pkgdesc = Reverse engineered Linux driver for the Broadcom 1570 PCIe webcam.
+ pkgver = 0r213.bb3c229
+ pkgrel = 1
+ url = https://github.com/patjak/bcwc_pcie
+ install = bcwc-pcie-dkms.install
+ arch = x86_64
+ license = unknown
+ makedepends = git
+ depends = kmod
+ depends = bcwc-pcie-firmware
+ depends = dkms
+ depends = linux-headers
+ provides = bcwc-pcie
+ conflicts = bcwc-pcie
+ conflicts = bcwc-pcie-git
+ source = bcwc-pcie-dkms::git+https://github.com/patjak/bcwc_pcie.git
+ source = bcwc-pcie.modprobe.conf
+ source = bcwc-pcie.modules-load.conf
+ source = dkms.conf
+ md5sums = SKIP
+ md5sums = 7531f220d5c3dd0ab5c31c445d526d7f
+ md5sums = d8dc0e4e125b7887b226bda0c28f30be
+ md5sums = 8233699ece37142eeae95cd67eb5298b
+
+pkgname = bcwc-pcie-dkms
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..09f0c7303318
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Hugo Osvaldo Barrera <hugo@barrera.io>
+
+pkgname="bcwc-pcie-dkms"
+pkgver=0r213.bb3c229
+pkgrel=1
+pkgdesc="Reverse engineered Linux driver for the Broadcom 1570 PCIe webcam."
+arch=('x86_64')
+url="https://github.com/patjak/bcwc_pcie"
+license=('unknown')
+depends=('kmod' 'bcwc-pcie-firmware' 'dkms' 'linux-headers')
+makedepends=('git')
+conflicts=("bcwc-pcie" "bcwc-pcie-git")
+provides=("bcwc-pcie")
+install="$pkgname.install"
+
+source=("$pkgname::git+https://github.com/patjak/bcwc_pcie.git"
+ "bcwc-pcie.modprobe.conf"
+ "bcwc-pcie.modules-load.conf"
+ "dkms.conf")
+md5sums=('SKIP'
+ '7531f220d5c3dd0ab5c31c445d526d7f'
+ 'd8dc0e4e125b7887b226bda0c28f30be'
+ '8233699ece37142eeae95cd67eb5298b')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ printf "0r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/"
+
+ install -Dm 644 dkms.conf "${pkgdir}/usr/src/bcwc-pcie-${pkgver}/dkms.conf"
+
+ cd $srcdir/$pkgname
+ for FILE in $(find -type f); do
+ install -Dm 644 "$FILE" "$pkgdir/usr/src/${pkgname/-dkms/}-${pkgver}/$FILE"
+ done
+
+ install -Dm 644 "$srcdir/bcwc-pcie.modprobe.conf" \
+ "$pkgdir/etc/modprobe.d/bcwc-pcie.conf"
+ install -Dm 644 "$srcdir/bcwc-pcie.modules-load.conf" \
+ "${pkgdir}/etc/modules-load.d/bcwc-pcie.conf"
+}
diff --git a/bcwc-pcie-dkms.install b/bcwc-pcie-dkms.install
new file mode 100644
index 000000000000..9b9fdb1bbe5a
--- /dev/null
+++ b/bcwc-pcie-dkms.install
@@ -0,0 +1,29 @@
+post_install() {
+ dkms_install $1
+}
+
+pre_upgrade() {
+ dkms_remove $2
+}
+
+post_upgrade() {
+ dkms_install $1
+}
+
+pre_remove () {
+ dkms_remove $1
+}
+
+dkms_remove() {
+ local line=`dkms status -m bcwc-pcie`
+ if echo "$line" | grep -E 'added|built|installed'; then
+ dkms remove -m bcwc-pcie -v ${1%%-*} --all
+ fi
+}
+
+dkms_install() {
+ dkms install -m bcwc-pcie -v ${1%%-*}
+ modprobe facetimehd
+
+ /usr/bin/depmod -a
+}
diff --git a/bcwc-pcie.modprobe.conf b/bcwc-pcie.modprobe.conf
new file mode 100644
index 000000000000..25aed20c6a39
--- /dev/null
+++ b/bcwc-pcie.modprobe.conf
@@ -0,0 +1 @@
+blacklist bdc_pci
diff --git a/bcwc-pcie.modules-load.conf b/bcwc-pcie.modules-load.conf
new file mode 100644
index 000000000000..0b6e56bd2eac
--- /dev/null
+++ b/bcwc-pcie.modules-load.conf
@@ -0,0 +1 @@
+facetimehd
diff --git a/dkms.conf b/dkms.conf
new file mode 100644
index 000000000000..46aaf3e3dfcf
--- /dev/null
+++ b/dkms.conf
@@ -0,0 +1,5 @@
+PACKAGE_NAME="bcwc-pcie"
+PACKAGE_VERSION="1.0.0"
+BUILT_MODULE_NAME[0]="facetimehd"
+DEST_MODULE_LOCATION[0]="/updates"
+AUTOINSTALL="yes"