summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--LICENSE9
-rw-r--r--PKGBUILD12
-rwxr-xr-xbeaker-browser2
4 files changed, 21 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cdb26f8bef71..058665ac670b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = beaker-browser-git
pkgdesc = Peer-to-peer browser with tools to create and host websites
pkgver = 0.8.10.r2.g54651db80
- pkgrel = 1
+ pkgrel = 2
url = https://beakerbrowser.com/
arch = x86_64
license = Modified MIT License (MIT)
@@ -23,9 +23,11 @@ pkgbase = beaker-browser-git
source = beaker-browser-git::git://github.com/beakerbrowser/beaker.git
source = beaker-browser.desktop
source = beaker-browser
+ source = LICENSE
md5sums = SKIP
md5sums = 34b48b022c6c71212f0adb3981f2925d
- md5sums = 09aa78a4ebb98e0c71aeaaf46fd6b11b
+ md5sums = 8aa20f048e0e071073bcf65f6864040d
+ md5sums = 3862c029863f42c81265a712f9c17c4c
pkgname = beaker-browser-git
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..e2f98ff7666e
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,9 @@
+Modified MIT License (MIT)
+
+Copyright (c) 2017 Paul Frazee
+
+Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE. \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 29352ed3e58a..f32c5773ee33 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=beaker-browser-git
pkgver=0.8.10.r2.g54651db80
-pkgrel=1
+pkgrel=2
pkgdesc="Peer-to-peer browser with tools to create and host websites"
arch=('x86_64')
url="https://beakerbrowser.com/"
@@ -19,10 +19,12 @@ backup=()
options=(!strip)
source=("beaker-browser-git::git://github.com/beakerbrowser/beaker.git"
"beaker-browser.desktop"
- "beaker-browser")
+ "beaker-browser"
+ "LICENSE")
md5sums=('SKIP'
'34b48b022c6c71212f0adb3981f2925d'
- '09aa78a4ebb98e0c71aeaaf46fd6b11b')
+ '8aa20f048e0e071073bcf65f6864040d'
+ '3862c029863f42c81265a712f9c17c4c')
pkgver() {
cd ${srcdir}/${pkgname}
@@ -45,8 +47,8 @@ prepare() {
package() {
### builded
- install -d ${pkgdir}/opt/beaker-browser
- cp -r ${srcdir}/${pkgname}/dist/linux-unpacked/* ${pkgdir}/opt/beaker-browser/
+ install -d ${pkgdir}/usr/share/beaker-browser
+ cp -r ${srcdir}/${pkgname}/dist/linux-unpacked/* ${pkgdir}/usr/share/beaker-browser/
### tools
install -Dm644 ${srcdir}/beaker-browser.desktop ${pkgdir}/usr/share/applications/beaker-browser.desktop
diff --git a/beaker-browser b/beaker-browser
index 419f405481e4..abe7f7d0fbe3 100755
--- a/beaker-browser
+++ b/beaker-browser
@@ -1,4 +1,4 @@
#!/bin/bash
# Launch application
-/opt/beaker-browser/beaker-browser
+/usr/share/beaker-browser/beaker-browser