summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO1
-rw-r--r--.gitignore6
-rw-r--r--Makefile1
-rw-r--r--PKGBUILD42
4 files changed, 13 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 61b758eadf59..ff9614bfce13 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -14,6 +14,7 @@ pkgbase = beakerbrowser
makedepends = git
depends = electron
depends = nodejs
+ depends = p7zip
optdepends = gksu: sudo-save support
source = git+https://github.com/beakerbrowser/beaker.git
source = beakerbrowser
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..95223da051a7
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+#folders
+pkg
+src
+
+#files
+*.pkg.tar.xz \ No newline at end of file
diff --git a/Makefile b/Makefile
index 05d5c10c7e63..9695677aabdf 100644
--- a/Makefile
+++ b/Makefile
@@ -18,6 +18,7 @@ prepare-push:
makepkg --printsrcinfo > .SRCINFO
uploadpkg:
+ makepkg --printsrcinfo > .SRCINFO
git add PKGBUILD .SRCINFO beakerbrowser beakerbrowser.desktop beakerbrowser.install LICENSE Makefile
sum_pkg:
diff --git a/PKGBUILD b/PKGBUILD
index 08b7a842349f..cec4df2c9da0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -111,8 +111,6 @@ package() {
cd "${srcdir}/beaker"
- ls
-
#Before install icons and data
#Copy icons for Desktop Integration
install -Dm644 build/icons/48x48.png \
@@ -120,26 +118,14 @@ package() {
mv * "${pkgdir}/opt/${pkgname}/"
- #exit 1
-
- #cp -R --preserve=mode "beaker/*" "${pkgdir}/opt/${pkgname}/"
fi
- #mv "${pkgdir}/beakerbrowser/*" "${pkgdir}/opt/${pkgname}/"
-
- #cp -rf "${srcdir}/beaker" "${pkgdir}/opt/${pkgname}"
-
- #cp -R --preserve=mode "${srcdir}/beaker" "${pkgdir}/opt/${pkgname}"
- #install -Dm755 "${srcdir}/beaker" "${pkgdir}/opt/${pkgname}"
- #chmod a+rx ${pkgdir}/opt/${pkgname}
-
echo -e "\033[1;31m==> Copy binaries \033[1;0m \033[1;1m$1\033[1;0m" >&2
cd "${srcdir}"
# Install Binaries/Launchers
install -Dm755 ${pkgname} "$pkgdir"/usr/bin/${pkgname}
- #ln -s /opt/${pkgname} ${pkgdir}/usr/bin/${pkgname}
#copy launcher to desktop
install -Dm644 "${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
@@ -150,29 +136,11 @@ package() {
echo -e "\033[1;31m==> FIX permissions \033[1;0m \033[1;1m$1\033[1;0m" >&2
# Fix wonky permissions
- chown -R $USER /usr/local
- #chown -R $USER "${pkgdir}/opt/${pkgname}/node_modules/*"
- #chown -R $USER "${pkgdir}/opt/${pkgname}/app/node_modules/*"
- #chmod 765 "${pkgdir}/opt/${pkgname}/node_modules/*"
- #chmod 765 "${pkgdir}/opt/${pkgname}/app/node_modules/*"
-
- chown -R $('whoami') /opt/beakerbrowser
-
- #find "${pkgdir}/opt/${pkgname}" -type d -exec chmod 755 {} \;
- #find "${pkgdir}/opt/${pkgname}" -type f -exec chmod 644 {} \;
- #chmod 755 "${pkgdir}/opt/${pkgname}"
-
- #sudo find /opt/beakerbrowser/node_modules/* -type d -exec chmod 755 {} \;
- #find "${pkgdir}/opt/${pkgname}/node_modules/*" -type d -exec chmod 755 {} \;
- #find "${pkgdir}/opt/${pkgname}/app/node_modules/*" -type d -exec chmod 755 {} \;
-
- #sudo chown -R $("whoami") /opt/${pkgname}
-
- #find "/opt/${pkgname}/node_modules/*" -type d -exec chmod 755 {} \;
- #find "/opt/${pkgname}/app/node_modules/*" -type d -exec chmod 755 {} \;
-
-
- #which beakerbrowser
+ if [ -d "/opt/beakerbrowser" ]; then
+
+ chown -R $USER /usr/local
+ chown -R $('whoami') /opt/beakerbrowser
+ fi
echo -e "\033[1;31m==> The package is completed .... \033[1;0m \033[1;1m$1\033[1;0m" >&2
} \ No newline at end of file