summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD18
2 files changed, 17 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2576cae1de95..ab0a9c1d3c4b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = beakerlib
pkgdesc = Shell-level integration testing library, providing convenience functions which simplify writing, running and analysis of integration and blackbox tests.
- pkgver = 1.29.3
- pkgrel = 2
+ pkgver = 1.30
+ pkgrel = 1
url = https://github.com/beakerlib/beakerlib
arch = i686
arch = x86_64
license = GPL2
makedepends = perl
- source = beakerlib-1.29.3.tar.gz::https://github.com/beakerlib/beakerlib/archive/refs/tags/1.29.3.tar.gz
- sha256sums = f792b86bac8be1a4593dd096c32c1a061102c802c6f5760259a5753b13f6caa1
+ source = beakerlib-1.30.tar.gz::https://github.com/beakerlib/beakerlib/archive/refs/tags/1.30.tar.gz
+ sha256sums = bd06fc61b32d9caf4324587706a8363e37e771355da8297d0c5ba0023ae31098
pkgname = beakerlib
diff --git a/PKGBUILD b/PKGBUILD
index 6fdd9a43c609..77b527dcb0ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Patrick Northon <northon_patrick3@yahoo.ca>
pkgname=beakerlib
-pkgver=1.29.3
-pkgrel=2
+pkgver=1.30
+pkgrel=1
pkgdesc="Shell-level integration testing library, providing convenience functions which simplify writing, running and analysis of integration and blackbox tests."
arch=('i686' 'x86_64')
url="https://github.com/beakerlib/beakerlib"
@@ -10,16 +10,24 @@ license=('GPL2')
depends=()
makedepends=('perl')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/beakerlib/beakerlib/archive/refs/tags/${pkgver}.tar.gz")
-sha256sums=('f792b86bac8be1a4593dd096c32c1a061102c802c6f5760259a5753b13f6caa1')
+sha256sums=('bd06fc61b32d9caf4324587706a8363e37e771355da8297d0c5ba0023ae31098')
_srcdir="${pkgname}-${pkgver}"
+prepare() {
+ cd "${_srcdir}"
+ sed -i 's/install: build/install:/' 'Makefile' 'src/Makefile'
+}
+
build() {
cd "${_srcdir}"
- make
+ make build
}
package() {
cd "${_srcdir}"
- make DD="${pkgdir}" install
+ make DESTDIR="${pkgdir}/usr" install
+
+ mkdir -p "${pkgdir}/usr/lib/tmpfiles.d"
+ install -m0644 "dist/${pkgname}-tmpfiles.conf" "${pkgdir}/usr/lib/tmpfiles.d/${pkgname}.conf"
}