summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--0001-Makefile-fix-order-of-execution.patch30
-rw-r--r--PKGBUILD39
-rw-r--r--beamercolortheme-owl.install7
5 files changed, 98 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5e87f0c6b2fb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Tue Jul 19 19:39:47 UTC 2016
+pkgbase = beamercolortheme-owl-git
+ pkgdesc = Theme that maximizes visibility in dark and unfavourable conditions
+ pkgver = v0.1.1.r2.g189e749
+ pkgrel = 1
+ url = https://github.com/rchurchley/beamercolortheme-owl
+ install = beamercolortheme-owl.install
+ arch = any
+ license = custom: none
+ depends = texlive-core
+ source = git+https://github.com/rchurchley/beamercolortheme-owl.git
+ source = 0001-Makefile-fix-order-of-execution.patch
+ sha512sums = SKIP
+ sha512sums = ff6a81df0035d76abcab1849a1625799fb716edd0d8802ea7f44e4a1a1a0bf3a68950c95d9fc42bc39b59052ac1b0c7201e9a22360f6436b3203baeef2ea4b47
+
+pkgname = beamercolortheme-owl-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..dbcf84117a3d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.pkg*
+pkg/
+src/
+beamercolortheme-owl/
diff --git a/0001-Makefile-fix-order-of-execution.patch b/0001-Makefile-fix-order-of-execution.patch
new file mode 100644
index 000000000000..da85eb5d8452
--- /dev/null
+++ b/0001-Makefile-fix-order-of-execution.patch
@@ -0,0 +1,30 @@
+From 275f92e382f1f8287566282a972378a6cfba9a52 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Leonard=20K=C3=B6nig?= <leonard.r.koenig@googlemail.com>
+Date: Tue, 19 Jul 2016 21:26:54 +0200
+Subject: [PATCH] [Makefile] fix order of execution
+
+---
+ Makefile | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index c5ea74c..fac717c 100644
+--- a/Makefile
++++ b/Makefile
+@@ -48,11 +48,11 @@ clean-sty:
+ $(CACHE_DIR):
+ @mkdir -p $(CACHE_DIR)
+
+-$(PACKAGE_STY): $(PACKAGE_SRC) $(INS) | $(CACHE_DIR) clean-cache
++$(PACKAGE_STY): $(PACKAGE_SRC) $(INS) | clean-cache $(CACHE_DIR)
+ @cd $(dir $(INS)) && latex -output-directory=$(CACHE_DIR) $(notdir $(INS))
+ @cp $(addprefix $(CACHE_DIR)/,$(PACKAGE_STY)) .
+
+-$(DOC_PDF): %.pdf: %.dtx $(PACKAGE_STY) | $(CACHE_DIR) clean-cache
++$(DOC_PDF): %.pdf: %.dtx $(PACKAGE_STY) | clean-cache $(CACHE_DIR)
+ $(COMPILE_TEX) $<
+ @cp $(CACHE_DIR)/$(notdir $@) $@
+
+--
+2.9.0
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9573a9f9564c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Leonard Koenig <leonard.r.koenig@gmail.com>
+_pkgname=beamercolortheme-owl
+pkgname=${_pkgname}-git
+pkgver=v0.1.1.r2.g189e749
+pkgrel=1
+pkgdesc="Theme that maximizes visibility in dark and unfavourable conditions"
+url="https://github.com/rchurchley/${_pkgname}"
+arch=("any")
+license=("custom: none")
+depends=("texlive-core")
+source=("git+https://github.com/rchurchley/${_pkgname}.git"
+ "0001-Makefile-fix-order-of-execution.patch")
+install=${_pkgname}.install
+sha512sums=('SKIP'
+ 'ff6a81df0035d76abcab1849a1625799fb716edd0d8802ea7f44e4a1a1a0bf3a68950c95d9fc42bc39b59052ac1b0c7201e9a22360f6436b3203baeef2ea4b47')
+
+pkgver() {
+ # Identify latest version.
+ cd "$srcdir/${_pkgname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ # Fix Makefile dependencies / rule order of execution
+ cd "$srcdir/${_pkgname}"
+ git apply $srcdir/0001-Makefile-fix-order-of-execution.patch
+}
+
+build() {
+ # Generate the style files.
+ cd $srcdir/${_pkgname}
+ make sty
+}
+
+package() {
+ TEXMFDIST=$(kpsewhich -var-value=TEXMFDIST)
+ cd $srcdir/${_pkgname}
+ make DESTDIR=$pkgdir/$TEXMFDIST install
+}
diff --git a/beamercolortheme-owl.install b/beamercolortheme-owl.install
new file mode 100644
index 000000000000..5c1a5c3ab12c
--- /dev/null
+++ b/beamercolortheme-owl.install
@@ -0,0 +1,7 @@
+post_install() {
+ mktexlsr
+}
+
+post_remove(){
+ post_install
+}