summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD73
2 files changed, 47 insertions, 56 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 682b2002e833..60127f305554 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,27 @@
pkgbase = beancount-import-git
- pkgver = 1.0.7.r0.0341cf8
+ pkgdesc = Semi-automatic importer from external data sources into beancount
+ pkgver = 1.3.5.r20.g59615a5
pkgrel = 1
- url = https://beancount.github.io/fava/
+ url = https://github.com/jbms/beancount-import
arch = any
license = MIT
makedepends = git
+ makedepends = npm
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = beancount
- depends = python>=3.5
- depends = python-setuptools
- depends = python-tornado
- depends = python-scikit-learn
- depends = python-nltk
- depends = python-dateutil
+ depends = python
depends = python-atomicwrites
+ depends = python-dateutil
depends = python-jsonschema
- provides = beancount-import=1.0.7
- conflicts = beancount-import
- source = git://github.com/jbms/beancount-import.git
- md5sums = SKIP
+ depends = python-nltk
+ depends = python-numpy
+ depends = python-scipy
+ depends = python-scikit-learn
+ depends = python-tornado
+ depends = python-watchdog
+ source = git+https://github.com/jbms/beancount-import
+ sha256sums = SKIP
pkgname = beancount-import-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 1ccb39932013..f3fb31d94829 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,52 +1,39 @@
-# Maintainer: Carlos José Ruiz-Henestrosa Ruiz <ruizh.cj@gmail.com>
-pkgname=beancount-import-git
-_name=${pkgname%-git}
-pkgver=1.3.3.r2.bd39126
+# Maintainer: AlphaJack <alphajack at tuta dot io>
+# Contributor: Carlos José Ruiz-Henestrosa Ruiz <ruizh.cj@gmail.com>
+
+pkgname="beancount-import-git"
+pkgver=1.3.5.r20.g59615a5
pkgrel=1
pkgdesc="Semi-automatic importer from external data sources into beancount"
-arch=('any')
url="https://github.com/jbms/beancount-import"
-license=('MIT')
-depends=('beancount>=2.1.3'
- 'python>=3.5'
- 'python-setuptools'
- 'python-tornado'
- 'python-numpy'
- 'python-scipy'
- 'python-scikit-learn'
- 'python-nltk'
- 'python-dateutil'
- 'python-atomicwrites>=1.3.0'
- 'python-jsonschema'
- 'python-watchdog')
-
-makedepends=('git')
-
-provides=("beancount-import=${pkgver%%.r*}")
-conflicts=("beancount-import")
-source=('git://github.com/jbms/beancount-import.git')
-md5sums=('SKIP')
-
-pkgver() {
- cd "$srcdir/${_name}"
+arch=("any")
+license=("MIT")
+depends=("beancount"
+ "python"
+ "python-atomicwrites"
+ "python-dateutil"
+ "python-jsonschema"
+ "python-nltk"
+ "python-numpy"
+ "python-scipy"
+ "python-scikit-learn"
+ "python-tornado"
+ "python-watchdog")
+makedepends=("git" "npm" "python-build" "python-installer" "python-wheel")
+source=("git+$url")
+sha256sums=("SKIP")
- # The repo does not tag releases, so we have to get creative
- _release_commit=$(git log -L '/version=/',+1:setup.py \
- --max-count=1 --pretty="format:%h" | \
- head --lines=1)
- _ver=$(grep version setup.py | cut --delimiter="'" --fields=2)
- printf "%s.r%s.%s" \
- "${_ver}" \
- "$(git rev-list --count ${_release_commit}..HEAD)" \
- "$(git rev-parse --short HEAD)"
+pkgver(){
+ cd "beancount-import"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
}
-build() {
- cd "$srcdir/${_name}"
- python setup.py build
+build(){
+ cd "beancount-import"
+ python -m build --wheel --no-isolation
}
-package() {
- cd "$srcdir/${_name}"
- python setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
+package(){
+ cd "beancount-import"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}