summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD22
-rw-r--r--bebas_neue.install16
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3cb8c04a1374
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = bebas_neue
+ pkgdesc = Bebas Neue is a sans serif font family based on the original Bebas Neue free font by Ryoichi Tsunekawa.
+ pkgver = 20150506
+ pkgrel = 1
+ url = http://fontfabric.com/bebas-neue/
+ install = bebas_neue.install
+ arch = any
+ license = custom:FONTFABRIC(tm) FREE FONT END USER LICENSE AGREEMENT v1.0 2009
+ source = bebas-20150506.zip::http://fontfabric.com/downfont/bebas.zip
+ md5sums = efecbc6a12926cce38b7c380edbb15c5
+
+pkgname = bebas_neue
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c97b38072604
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: James Morris - jwm-art - james@jwm-art.net
+# Contributor: Manuel Hüsers <manuel.huesers@uni-ol.de>
+
+pkgname=bebas_neue
+pkgver=20150506
+pkgrel=1
+#depends=('fontconfig' 'xorg-font-utils')
+pkgdesc="Bebas Neue is a sans serif font family based on the original Bebas Neue free font by Ryoichi Tsunekawa."
+arch=('any')
+url="http://fontfabric.com/bebas-neue/"
+license=('custom:FONTFABRIC(tm) FREE FONT END USER LICENSE AGREEMENT v1.0 2009')
+source=(bebas-${pkgver}.zip::http://fontfabric.com/downfont/bebas.zip)
+install=$pkgname.install
+md5sums=('efecbc6a12926cce38b7c380edbb15c5')
+
+package() {
+ cd "${srcdir}" || return 1
+ install -dm755 "${pkgdir}/usr/share/fonts/OTF" || return 1
+ install -m644 *.otf "${pkgdir}/usr/share/fonts/OTF" || return 1
+ install -dm755 "${pkgdir}/usr/share/licenses/${pkgname}" || return 1
+ install -m644 'FFF_EULA_license.pdf' "${pkgdir}/usr/share/licenses/${pkgname}/eula.pdf" || return 1
+}
diff --git a/bebas_neue.install b/bebas_neue.install
new file mode 100644
index 000000000000..58372246f8a2
--- /dev/null
+++ b/bebas_neue.install
@@ -0,0 +1,16 @@
+post_install () {
+ echo Updating font cache....
+ fc-cache -fs
+ mkfontscale /usr/share/fonts/OTF
+ mkfontdir /usr/share/fonts/OTF
+}
+
+post_upgrade () {
+ post_install "$1"
+}
+
+post_remove () {
+ post_install "$1"
+}
+
+# vim:set ts=2 sw=2 et: