summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
-rw-r--r--beecrypt-4.2.1-icu-61.patch51
3 files changed, 68 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d3941d4ffb6d..e5984fde1abd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Sun Nov 11 16:36:38 UTC 2018
pkgbase = beecrypt
pkgdesc = A strong and fast cryptography toolkit
pkgver = 4.2.1
- pkgrel = 5
+ pkgrel = 6
url = http://beecrypt.sourceforge.net/
arch = i686
arch = x86_64
@@ -10,7 +12,9 @@ pkgbase = beecrypt
depends = icu
options = !libtool
source = http://downloads.sourceforge.net/sourceforge/beecrypt/beecrypt-4.2.1.tar.gz
+ source = beecrypt-4.2.1-icu-61.patch
sha256sums = 286f1f56080d1a6b1d024003a5fa2158f4ff82cae0c6829d3c476a4b5898c55d
+ sha256sums = 172a878f04f94586fbf7506c9809f580ff6025cda9a4a97ba168ae363e72f8e3
pkgname = beecrypt
diff --git a/PKGBUILD b/PKGBUILD
index 51cd28d0dc06..d32a5a78656e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=beecrypt
pkgver=4.2.1
-pkgrel=5
+pkgrel=6
pkgdesc="A strong and fast cryptography toolkit"
arch=('i686' 'x86_64')
url="http://beecrypt.sourceforge.net/"
@@ -10,8 +10,17 @@ license=('LGPL')
depends=('icu')
makedepends=('python2')
options=('!libtool')
-source=(http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.gz)
-sha256sums=('286f1f56080d1a6b1d024003a5fa2158f4ff82cae0c6829d3c476a4b5898c55d')
+source=(http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.gz
+ $pkgname-$pkgver-icu-61.patch)
+sha256sums=('286f1f56080d1a6b1d024003a5fa2158f4ff82cae0c6829d3c476a4b5898c55d'
+ '172a878f04f94586fbf7506c9809f580ff6025cda9a4a97ba168ae363e72f8e3')
+
+prepare() {
+ cd "${srcdir}"/$pkgname-$pkgver
+
+ patch -Np1 -i "${srcdir}"/$pkgname-$pkgver-icu-61.patch
+}
+
build() {
cd "${srcdir}"/$pkgname-$pkgver
diff --git a/beecrypt-4.2.1-icu-61.patch b/beecrypt-4.2.1-icu-61.patch
new file mode 100644
index 000000000000..68845f612d9b
--- /dev/null
+++ b/beecrypt-4.2.1-icu-61.patch
@@ -0,0 +1,51 @@
+On icu-61 built failures look like:
+ include/beecrypt/c++/lang/String.h:76:17:
+ error: ‘UnicodeString’ does not name a type
+
+ICU-61 moved all names into icu:: space.
+
+The fix is to add 'using icu::<symbol>'.
+
+Reported-by: Juergen Rose
+Bug: https://bugs.gentoo.org/666542
+--- a/c++/beeyond/DHIESParameterSpec.cxx
++++ b/c++/beeyond/DHIESParameterSpec.cxx
+@@ -36,2 +36,4 @@ using std::auto_ptr;
+ #include <unicode/numfmt.h>
++using icu::RegexPattern;
++using icu::RegexMatcher;
+
+--- a/c++/crypto/Cipher.cxx
++++ b/c++/crypto/Cipher.cxx
+@@ -30,2 +30,4 @@ using beecrypt::security::Security;
+ #include <unicode/ustream.h>
++using icu::RegexMatcher;
++using icu::RegexPattern;
+
+--- a/c++/lang/Integer.cxx
++++ b/c++/lang/Integer.cxx
+@@ -29,2 +29,5 @@ using beecrypt::lang::String;
+ #include <unicode/numfmt.h>
++using icu::Formattable;
++using icu::NumberFormat;
++
+
+--- a/c++/lang/Long.cxx
++++ b/c++/lang/Long.cxx
+@@ -29,2 +29,4 @@ using beecrypt::lang::String;
+ #include <unicode/numfmt.h>
++using icu::Formattable;
++using icu::NumberFormat;
+
+--- a/c++/util/Date.cxx
++++ b/c++/util/Date.cxx
+@@ -28,2 +28,3 @@
+ #include <unicode/datefmt.h>
++using icu::DateFormat;
+
+--- a/include/beecrypt/c++/lang/String.h
++++ b/include/beecrypt/c++/lang/String.h
+@@ -41,2 +41,3 @@ using beecrypt::bytearray;
+ #include <unicode/unistr.h>
++using icu::UnicodeString;
+