summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD10
1 files changed, 10 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 18684c064af3..14ecddfe6782 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -51,6 +51,16 @@ build() {
DEBUG='*' NODE_OPTIONS='--openssl-legacy-provider' yarn run vue-cli-service electron:build
}
+check() {
+ cd "$srcdir/$_sourcedirectory/apps/studio/"
+
+ # Run unit tests
+ yarn run test:unit --ci
+
+ # Not running tests, as they are currently not repeatable and the sqlserver test suite does not work
+ # yarn run test:integration --runInBand --ci --testPathIgnorePatterns=sqlserver.spec.js
+}
+
package() {
# Electron resources
cd "$srcdir/$_sourcedirectory/apps/studio/dist_electron/"