summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO44
-rw-r--r--PKGBUILD46
2 files changed, 70 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d34fae396032..7e91ffbb46a6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,49 @@
pkgbase = beets-git
pkgdesc = Flexible music library manager and tagger - git version
- pkgver = 1.4.3.r29.g70fd6cb7
+ pkgver = 1.4.9.r42.g81b1faa05
pkgrel = 1
url = http://beets.io/
arch = any
license = MIT
+ makedepends = python-setuptools
makedepends = git
- depends = python-munkres
- depends = python-mutagen
- depends = python-setuptools
+ depends = python-six
depends = python-unidecode
depends = python-musicbrainzngs
depends = python-yaml
+ depends = python-mediafile
+ depends = python-confuse
+ depends = python-munkres
depends = python-jellyfish
- depends = python-six
- optdepends = python-pyacoustid: acoustic fingerprinting
- optdepends = python-flask: web interface
- optdepends = python-gobject: BPD audio player plugin
- optdepends = python-pylast: lastgenre plugin
+ optdepends = python-requests: absubmit, fetchart, embyupdate, kodiupdate, lyrics, plexupdate plugins
+ optdepends = python-pillow: fetchart, embedart, thumbnails plugins
+ optdepends = python-pyacoustid: chroma plugin
+ optdepends = python-gobject: bpd, replaygain plugins
+ optdepends = python-gmusicapi: gmusic plugin
+ optdepends = python-discogs-client: discogs plugin
+ optdepends = python-requests-oauthlib: beatport plugin
+ optdepends = python-pylast: lastgenre, lastimport plugins
+ optdepends = python-beautifulsoup4: lyrics plugin
+ optdepends = python-mpd2: mpdstats plugin
+ optdepends = python-flask: web plugin
+ optdepends = python-flask-cors: web plugin
+ optdepends = python-rarfile: import plugin
+ optdepends = python-xdg: thumbnails plugin
+ optdepends = python-dbus: metasync plugin
+ optdepends = python-soco: sonosupdate plugin
+ optdepends = python-mutagen: scrub plugin
+ optdepends = chromaprint: chroma plugin
+ optdepends = ffmpeg: convert plugin
+ optdepends = mp3val: badfiles plugin
+ optdepends = flac: badfiles plugin
+ optdepends = gstreamer: bpd, replaygain plugins
+ optdepends = imagemagick: embedart plugin
+ optdepends = essentia-acousticbrainz: absubmit plugin
+ optdepends = keyfinder: keyfinder plugin
+ optdepends = mp3gain: replaygain plugin
+ optdepends = aacgain: replaygain plugin
+ optdepends = audiotools: replaygain plugin
+ optdepends = go-ipfs: ipfs plugin
provides = beets
conflicts = beets
source = git+https://github.com/beetbox/beets.git
diff --git a/PKGBUILD b/PKGBUILD
index 25314dbd794a..1bca261ffc6d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,45 @@
# Contributor: Johannes Löthberg <demizide@gmail.com>
pkgname=beets-git
-pkgver=1.4.3.r29.g70fd6cb7
+pkgver=1.4.9.r42.g81b1faa05
pkgrel=1
pkgdesc="Flexible music library manager and tagger - git version"
arch=('any')
url="http://beets.io/"
license=('MIT')
-depends=('python-munkres' 'python-mutagen'
- 'python-setuptools' 'python-unidecode'
- 'python-musicbrainzngs' 'python-yaml'
- 'python-jellyfish' 'python-six')
-makedepends=('git')
-optdepends=('python-pyacoustid: acoustic fingerprinting'
- 'python-flask: web interface'
- 'python-gobject: BPD audio player plugin'
- 'python-pylast: lastgenre plugin')
+depends=('python-six' 'python-unidecode' 'python-musicbrainzngs'
+ 'python-yaml' 'python-mediafile' 'python-confuse'
+ 'python-munkres' 'python-jellyfish')
+makedepends=('python-setuptools' 'git')
+optdepends=('python-requests: absubmit, fetchart, embyupdate, kodiupdate, lyrics, plexupdate plugins'
+ 'python-pillow: fetchart, embedart, thumbnails plugins'
+ 'python-pyacoustid: chroma plugin'
+ 'python-gobject: bpd, replaygain plugins'
+ 'python-gmusicapi: gmusic plugin'
+ 'python-discogs-client: discogs plugin'
+ 'python-requests-oauthlib: beatport plugin'
+ 'python-pylast: lastgenre, lastimport plugins'
+ 'python-beautifulsoup4: lyrics plugin'
+ 'python-mpd2: mpdstats plugin'
+ 'python-flask: web plugin'
+ 'python-flask-cors: web plugin'
+ 'python-rarfile: import plugin'
+ 'python-xdg: thumbnails plugin'
+ 'python-dbus: metasync plugin'
+ 'python-soco: sonosupdate plugin'
+ 'python-mutagen: scrub plugin'
+ 'chromaprint: chroma plugin'
+ 'ffmpeg: convert plugin'
+ 'mp3val: badfiles plugin'
+ 'flac: badfiles plugin'
+ 'gstreamer: bpd, replaygain plugins'
+ 'imagemagick: embedart plugin'
+ 'essentia-acousticbrainz: absubmit plugin'
+ 'keyfinder: keyfinder plugin'
+ 'mp3gain: replaygain plugin'
+ 'aacgain: replaygain plugin'
+ 'audiotools: replaygain plugin'
+ 'go-ipfs: ipfs plugin')
provides=('beets')
conflicts=('beets')
source=('git+https://github.com/beetbox/beets.git')
@@ -37,4 +61,4 @@ package() {
python setup.py install --root=${pkgdir} --optimize=1 --skip-build
install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-}
+}