summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d674f42a1947..72642225691b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = besu
pkgdesc = Hyperledger Ethereum Mainnet and Permissioned Network Client
- pkgver = 1.4.6
+ pkgver = 1.5.0
pkgrel = 1
url = https://www.hyperledger.org/use/besu
arch = any
license = Apache
depends = java-runtime>=11
replaces = pantheon
- source = besu-1.4.6.tar.gz::https://bintray.com/hyperledger-org/besu-repo/download_file?file_path=besu-1.4.6.tar.gz
- sha256sums = 7ac824a86f6a7bb704eda97b2a8597f48056895485c53eb057636035089d6030
+ source = besu-1.5.0.tar.gz::https://bintray.com/hyperledger-org/besu-repo/download_file?file_path=besu-1.5.0.tar.gz
+ sha256sums = 902bcd5003d080096c90ddda7d01d067e86effc44bceeb7a944950af201c8670
pkgname = besu
diff --git a/PKGBUILD b/PKGBUILD
index c628dac60f91..68f1176e885e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Ratan Rai Sur <ratan.r.sur@gmail.com>
pkgname=besu
-pkgver=1.4.6
+pkgver=1.5.0
pkgrel=1
pkgdesc="Hyperledger Ethereum Mainnet and Permissioned Network Client"
arch=('any')
@@ -10,15 +10,17 @@ depends=('java-runtime>=11')
replaces=('pantheon')
#changelog=
source=("$pkgname-$pkgver.tar.gz::https://bintray.com/hyperledger-org/$pkgname-repo/download_file?file_path=$pkgname-$pkgver.tar.gz")
-sha256sums=('7ac824a86f6a7bb704eda97b2a8597f48056895485c53eb057636035089d6030')
+sha256sums=('902bcd5003d080096c90ddda7d01d067e86effc44bceeb7a944950af201c8670')
check() {
"$pkgname-$pkgver/bin/$pkgname" --version
}
package() {
+ install -d "$pkgdir/opt/$pkgname"
+ install -d "$pkgdir/usr/bin"
cd "$pkgname-$pkgver"
- install -Dm755 "bin/$pkgname" "$pkgdir/usr/bin/$pkgname"
- install -d -Dm644 lib/ "$pkgdir/usr/share/besu/lib"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ rm bin/$pkgname.bat
+ cp -p -r * "$pkgdir/opt/$pkgname"
+ ln -rs "$pkgdir/opt/$pkgname/bin/$pkgname" "$pkgdir/usr/bin/$pkgname"
}