summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5ad9edfb1a4e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = bhsh
+ pkgdesc = A Unix-like blackhole shell
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/zolagonano/bhsh
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = base-devel
+ depends = rust
+ source = git+https://github.com/zolagonano/bhsh.git#tag=0.1.0
+ sha256sums = SKIP
+
+pkgname = bhsh
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4762a5340564
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Zola Gonano <zolagonano@protonmail.com>
+
+pkgname=bhsh
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="A Unix-like blackhole shell"
+arch=('x86_64')
+url="https://github.com/zolagonano/bhsh"
+license=('MIT')
+depends=('rust')
+makedepends=('git' 'base-devel')
+
+source=("git+https://github.com/zolagonano/bhsh.git#tag=$pkgver")
+sha256sums=("SKIP")
+
+build() {
+ cd "$srcdir/bhsh"
+
+ cargo build --release --locked
+}
+
+package() {
+ cd "$srcdir/bhsh"
+
+ strip "target/release/bhsh"
+ install -Dm755 "target/release/bhsh" "$pkgdir/usr/bin/bhsh"
+}
+