summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD12
-rw-r--r--makefile.patch2
3 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5c3219bbc319..163af69e79c6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = bible-kjv
pkgdesc = King James Bible, Concordance, and Command-Line Viewer
- pkgver = 4.36
- pkgrel = 1
- url = http://www.debian.org/
+ pkgver = 4.38
+ pkgrel = 3
+ url = https://tracker.debian.org/pkg/bible-kjv
arch = x86_64
license = GPL
makedepends = perl
depends = readline
- source = http://ftp.debian.org/debian/pool/main/b/bible-kjv/bible-kjv_4.36.tar.gz
+ source = https://ftp.debian.org/debian/pool/main/b/bible-kjv/bible-kjv_4.38.tar.gz
source = makefile.patch
- sha256sums = 9666d5ccc8b1763fef417c4c57ba2a5b4074a840b19731937226483e5dfeb5df
- sha256sums = 91bb9de66b17d67b72f5de57098928aa897ba62a77b5ddcf2695e74c0a97d572
+ sha256sums = 890b4d16fa2c0a9930fd4e6df22c6182b696ac0c1c47d12dc513227c62d8f249
+ sha256sums = aa8722a813d5dabd7f3f8a18b4c0b47d7c1a5680682bd15a1b2bc2871d553b19
pkgname = bible-kjv
diff --git a/PKGBUILD b/PKGBUILD
index 830dbb5ed352..4ec513537c1e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,18 @@
# Maintainer: Paul Clark <paul500clark at gmail dot com>
# Contributor: David Koenig <koenigdmj@gmail.com>
pkgname=bible-kjv
-pkgver=4.36
-pkgrel=1
+pkgver=4.38
+pkgrel=3
pkgdesc="King James Bible, Concordance, and Command-Line Viewer"
arch=(x86_64)
-url="http://www.debian.org/"
+url="https://tracker.debian.org/pkg/bible-kjv"
license=('GPL')
depends=('readline')
makedepends=('perl')
-source=(http://ftp.debian.org/debian/pool/main/b/${pkgname}/${pkgname}_${pkgver}.tar.gz
+source=(https://ftp.debian.org/debian/pool/main/b/${pkgname}/${pkgname}_${pkgver}.tar.gz
makefile.patch)
-sha256sums=('9666d5ccc8b1763fef417c4c57ba2a5b4074a840b19731937226483e5dfeb5df'
- '91bb9de66b17d67b72f5de57098928aa897ba62a77b5ddcf2695e74c0a97d572')
+sha256sums=('890b4d16fa2c0a9930fd4e6df22c6182b696ac0c1c47d12dc513227c62d8f249'
+ 'aa8722a813d5dabd7f3f8a18b4c0b47d7c1a5680682bd15a1b2bc2871d553b19')
package () {
patch -p1 < makefile.patch
diff --git a/makefile.patch b/makefile.patch
index b2520b5af667..295f430b2156 100644
--- a/makefile.patch
+++ b/makefile.patch
@@ -5,7 +5,7 @@ diff -aur src0/bible-kjv/Makefile src1/bible-kjv/Makefile
# I use environment variables for these...
#CFLAGS = -g
--CFLAGS = -Wall -Wformat -Werror -Wshadow -W -Wmissing-declarations -Wmissing-prototypes -Wstrict-prototypes -Wcast-align -Wcast-qual -Wbad-function-cast -Wpointer-arith -g2 -ggdb -DDESTLIB=\"$(DESTLIB)\"
+-CFLAGS = -Wall -Wformat -Werror -Wshadow -W -Wmissing-declarations -Wmissing-prototypes -Wstrict-prototypes -Wcast-align -Wcast-qual -Wbad-function-cast -Wpointer-arith -g2 -ggdb -DDESTLIB=\"$(DESTLIB)\" -ffile-prefix-map=$(CURDIR)=.
-LDFLAGS =
+CFLAGS += -DDESTLIB=\"$(DESTLIB)\"
LDADD = -lreadline