summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--makefile.patch15
3 files changed, 16 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 363d6e57e948..be075d332e7d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = bible-kjv
pkgdesc = King James Bible, Concordance, and Command-Line Viewer
pkgver = 4.29
- pkgrel = 2
+ pkgrel = 3
url = http://www.debian.org/
arch = i686
arch = x86_64
@@ -11,7 +11,7 @@ pkgbase = bible-kjv
source = http://ftp.debian.org/debian/pool/main/b/bible-kjv/bible-kjv_4.29.tar.gz
source = makefile.patch
md5sums = e08a001de6e436cb4554ffcb19c24d37
- md5sums = 17018de81419f5bc227669aa03639c0d
+ md5sums = e234e246b418fbd75a3855e321775a9e
pkgname = bible-kjv
diff --git a/PKGBUILD b/PKGBUILD
index 995d8347712d..f72e68bb57c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: David Koenig <koenigdmj@gmail.com>
pkgname=bible-kjv
pkgver=4.29
-pkgrel=2
+pkgrel=3
pkgdesc="King James Bible, Concordance, and Command-Line Viewer"
arch=(i686 x86_64)
url="http://www.debian.org/"
@@ -12,7 +12,7 @@ makedepends=('perl')
source=(http://ftp.debian.org/debian/pool/main/b/${pkgname}/${pkgname}_${pkgver}.tar.gz
makefile.patch)
md5sums=('e08a001de6e436cb4554ffcb19c24d37'
- '17018de81419f5bc227669aa03639c0d')
+ 'e234e246b418fbd75a3855e321775a9e')
package () {
patch -p1 < makefile.patch
diff --git a/makefile.patch b/makefile.patch
index 6b8f24d9af6c..d65c25dffab4 100644
--- a/makefile.patch
+++ b/makefile.patch
@@ -1,7 +1,16 @@
-diff -Naur src0/bible-kjv/Makefile src1/bible-kjv/Makefile
+diff -aur src0/bible-kjv/Makefile src1/bible-kjv/Makefile
--- src0/bible-kjv/Makefile 2011-06-25 13:20:00.000000000 +0100
-+++ src1/bible-kjv/Makefile 2015-05-31 20:09:48.435577487 +0100
-@@ -442,23 +443,17 @@
++++ src1/bible-kjv/Makefile 2018-05-03 16:30:18.151493296 +0100
+@@ -88,7 +88,7 @@
+
+ # I use environment variables for these...
+ #CFLAGS = -g
+-CFLAGS = -Wall -Wformat -Werror -Wshadow -W -Wmissing-declarations -Wmissing-prototypes -Wstrict-prototypes -Wcast-align -Wcast-qual -Wbad-function-cast -Wpointer-arith -g2 -ggdb -DDESTLIB=\"$(DESTLIB)\"
++CFLAGS = -O2 -DDESTLIB=\"$(DESTLIB)\"
+ LDFLAGS =
+ LDADD = -lreadline
+
+@@ -442,23 +442,17 @@
@if [ $(DESTBIN) != . ]; then \
((cd $(DESTBIN);rm -f $(PROGRAM)); \
cp $(PROGRAM) $(DESTBIN)); \