summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fa1c0ff32635..f93b305cf823 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = binance
pkgdesc = The Binance desktop application
- pkgver = 1.15.5
- pkgrel = 1
+ pkgver = 1.15.4
+ pkgrel = 2
url = https://www.binance.com/en/download
arch = x86_64
license = unknown
checkdepends = curl
checkdepends = coreutils
depends = electron
- source = binance-1.15.5.deb::https://ftp.binance.com/electron-desktop/linux/production/binance-amd64-linux.deb
+ source = binance-1.15.4.deb::https://ftp.binance.com/electron-desktop/linux/production/binance-amd64-linux.deb
sha256sums = 96add572427cc441e63637311f5c4151250140df813f75d904a8d69c93b7d1ba
pkgname = binance
diff --git a/PKGBUILD b/PKGBUILD
index 180183c24138..10c94f008745 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Maintainer: tyjak
pkgname=binance
-pkgver=1.15.5
-pkgrel=1
+pkgver=1.15.4
+pkgrel=2
pkgdesc="The Binance desktop application"
arch=('x86_64')
url="https://www.binance.com/en/download"
@@ -19,13 +19,16 @@ check() {
cd "$srcdir"
binancechecksums=$(curl https://ftp.binance.com/electron-desktop/linux/production/binance-amd64-linux-deb-sha256.txt)
echo "Checksum verification..."
+ echo "1 Binance :" $binancechecksums
+ echo "2 PKGBUILD:" $sha256sums
+ echo "3 Deb File:" $(sha256sum ${pkgname}-${pkgver}.deb)
+ echo "4 Compare :" $(sha256sum ${pkgname}-${pkgver}.deb | awk '{print $1}') $binancechecksums
[ "$sha256sums" == "$binancechecksums" ] \
&& echo -e "binance checksum file and PKGBUILD declared checksum: \e[1;32m\033[1mOK\033[0m\e[0m" \
|| (echo -e "binance checksum file and PKGBUILD declared checksum: \e[1;31m\033[1mKO\033[0m" && exit 1)
- [ "$(sha256sum ${pkgname}-${pkgver}.deb)" == "$binancechecksums" ] \
+ [ "$(sha256sum ${pkgname}-${pkgver}.deb | awk '{print $1}')" == "$binancechecksums" ] \
&& echo -e "deb checksum and binance file checksum: \e[1;32m\033[1mOK\033[0m\e[0m" \
|| (echo -e "deb checksum and binance file checksum: \e[1;31m\033[1mKO\033[0m\e[0m" && exit 1)
- exit 0
}
package() {