summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD11
2 files changed, 6 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index de685816366a..80718fae218f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,7 +8,7 @@ pkgbase = biomart
license = LGPL
depends = java-runtime
source = ftp://ftp.ebi.ac.uk/pub/software/biomart/martj_current/martj-bin.tar.gz
- md5sums = 9381d0fd3a76652bfbebc60b209d9e0c
+ sha256sums = a506f3632e61ec721494e7c43194ab6e807808cd087b8b82443eb0e8b3dcc1db
pkgname = biomart
diff --git a/PKGBUILD b/PKGBUILD
index 10bd9c2448bc..be2b4988f74a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,4 @@
# Maintainer: Michael Schubert <mschu.dev at google mail>
-
pkgname=biomart
pkgver=0.8
pkgrel=1
@@ -9,14 +8,14 @@ url="http://www.biomart.org/"
license=('LGPL')
depends=('java-runtime')
source=('ftp://ftp.ebi.ac.uk/pub/software/biomart/martj_current/martj-bin.tar.gz')
-md5sums=('9381d0fd3a76652bfbebc60b209d9e0c')
+sha256sums=('a506f3632e61ec721494e7c43194ab6e807808cd087b8b82443eb0e8b3dcc1db')
package() {
- mkdir -p $pkgdir/opt/biomart
- cp -r $srcdir/martj-bin/* $pkgdir/opt/biomart/
+ mkdir -p "$pkgdir"/opt/biomart
+ cp -r "$srcdir"/martj-bin/* "$pkgdir"/opt/biomart/
- mkdir -p $pkgdir/usr/bin
+ mkdir -p "$pkgdir"/usr/bin
for L in martbuilder marteditor martexplorer martregistrydbtool martrunner martshell; do
- ln -s /opt/biomart/bin/$L.sh $pkgdir/usr/bin/$L
+ ln -s /opt/biomart/bin/$L.sh "$pkgdir"/usr/bin/$L
done
}