summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO50
-rw-r--r--PKGBUILD79
-rw-r--r--biopieces.sh12
3 files changed, 141 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dd88b994c60b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,50 @@
+pkgbase = biopieces
+ pkgdesc = Bioinformatic framework of tools easily used and easily created
+ pkgver = r2311
+ pkgrel = 1
+ url = http://biopieces.googlecode.com/
+ arch = any
+ license = GPL2
+ makedepends = svn
+ depends = perl
+ depends = ruby
+ depends = perl-svg
+ depends = perl-bit-vector
+ depends = perl-term-readkey
+ depends = perl-dbi
+ depends = perl-xml-parser
+ depends = perl-carp-clan
+ depends = perl-class-inspector
+ depends = perl-html-parser
+ depends = perl-soap-lite
+ depends = perl-uri
+ depends = perl-inline
+ depends = perl-parse-recdescent
+ depends = perl-dbd-mysql
+ depends = ruby-gnuplot
+ depends = ruby-narray
+ depends = perl-json-xs
+ depends = python2
+ depends = ruby-rubyinline
+ depends = ruby-terminal-table
+ optdepends = rubyinline
+ optdepends = blast: legacy blast
+ optdepends = gnuplot
+ optdepends = blat
+ optdepends = ray
+ optdepends = bwa
+ optdepends = bowtie
+ optdepends = bowtie2
+ optdepends = hmmer
+ optdepends = mummer
+ optdepends = muscle
+ optdepends = velvet
+ source = biopieces::svn+http://biopieces.googlecode.com/svn/trunk
+ source = biopieces/bp_usage::svn+http://biopieces.googlecode.com/svn/wiki
+ source = biopieces.sh
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = 8ebebd698533ae818c8cfbef4fa8e9ca
+
+pkgname = biopieces
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..56bcbec7a45e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,79 @@
+# Maintainer: Sebastian Wilzbach < sebi at wilzbach dot me >
+pkgname=biopieces
+pkgver=r2311
+pkgrel=1
+epoch=
+pkgdesc="Bioinformatic framework of tools easily used and easily created"
+arch=("any")
+url="http://biopieces.googlecode.com/"
+license=('GPL2')
+groups=()
+depends=('perl' 'ruby' "perl-svg" "perl-bit-vector" "perl-term-readkey" "perl-dbi" "perl-xml-parser" "perl-carp-clan"
+ "perl-class-inspector" "perl-html-parser" "perl-soap-lite" "perl-uri" "perl-inline" "perl-parse-recdescent" "perl-dbd-mysql"
+ 'ruby-gnuplot' 'ruby-narray' 'perl-json-xs' 'python2' 'ruby-rubyinline' 'ruby-terminal-table')
+makedepends=("svn")
+checkdepends=()
+optdepends=('rubyinline' 'blast: legacy blast' 'gnuplot' 'blat' 'ray' 'bwa' 'bowtie' 'bowtie2' 'hmmer' 'mummer' 'muscle' 'velvet')
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("biopieces::svn+http://biopieces.googlecode.com/svn/trunk"
+"biopieces/bp_usage::svn+http://biopieces.googlecode.com/svn/wiki"
+"biopieces.sh")
+noextract=()
+md5sums=('SKIP'
+'SKIP'
+'8ebebd698533ae818c8cfbef4fa8e9ca')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ local ver="$(svnversion)"
+ printf "r%s" "${ver//[[:alpha:]]}"
+}
+
+package() {
+ cd "$pkgdir"
+ mkdir -p "opt/$pkgname"
+
+ cp -a "$srcdir/biopieces" "opt/"
+
+ # remove svn history
+ rm -r -f "opt/$pkgname/.svn"
+ rm -r -f "opt/$pkgname/bp_usage/.svn"
+ rm -r -f "opt/$pkgname/.makepkg"
+
+ # patch python2 scripts
+ find "opt/$pkgname/code_python" -type f -exec sed -i 's/#!\/usr\/bin\/python/&2/' {} \;
+
+ # install exports
+ install -Dm755 "$srcdir/$pkgname.sh" etc/profile.d/$pkgname.sh
+ source etc/profile.d/$pkgname.sh
+}
+
+check() {
+ cd "$srcdir/biopieces"
+
+ # set the constant for the test suite
+ export BP_DIR=$(pwd)
+ export BP_TMP=$BP_DIR"/tmp"
+ export BP_LOG="$BP_TMP/log"
+ mkdir -p $BP_LOG
+
+ # source the config
+ source "bp_conf/bashrc"
+
+ # permission to write on bp_test
+ chmod a+w "bp_test"
+ chmod a+w "bp_test/in"
+ chmod a+w "bp_test/out"
+
+ # calling test
+ /bin/bash "bp_test/test_all"
+
+ # remove unnecessary test output
+ rm -r -f $BP_TMP
+}
diff --git a/biopieces.sh b/biopieces.sh
new file mode 100644
index 000000000000..ef41177dfced
--- /dev/null
+++ b/biopieces.sh
@@ -0,0 +1,12 @@
+export BP_DIR="/opt/biopieces/" # Directory where biopieces are installed
+export BP_DATA="~/.biopieces/data" # Contains genomic data etc.
+export BP_TMP="/tmp/biopieces" # Required temporary directory.
+export BP_LOG="/tmp/biopieces/log" # Required log directory.
+
+# create log dir
+mkdir -p $BP_LOG
+
+if [ -f "$BP_DIR/bp_conf/bashrc" ]; then
+ source "$BP_DIR/bp_conf/bashrc"
+fi
+