aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD8
-rw-r--r--README5
-rw-r--r--bipscript-v0.7.patch24
4 files changed, 38 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c8c28357a4d5..0d01bd8098e0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = bipscript
pkgdesc = A scripting language for interactive music
- pkgver = 0.6
+ pkgver = 0.7
pkgrel = 1
url = http://www.bipscript.org
arch = i686
@@ -17,10 +17,10 @@ pkgbase = bipscript
depends = portsmf
provides = bipscript
conflicts = bipscript
- source = https://github.com/bipscript/bipscript/archive/v0.6.tar.gz
- source = bipscript-v0.6.patch
- md5sums = 085193d085486b9b641ea52ca8e8230e
- md5sums = c775c269b2b654289b93e34858a85699
+ source = https://github.com/bipscript/bipscript/archive/v0.7.tar.gz
+ source = bipscript-v0.7.patch
+ md5sums = ccbf7ce80d8ef19c55d15b226d7b8cef
+ md5sums = 38886856c32d00d420bdf07e7469cfd5
pkgname = bipscript
diff --git a/PKGBUILD b/PKGBUILD
index ecd78e2d6155..0304febce296 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: John Hammen <jhammen@j2page.com>
pkgname=bipscript
-pkgver=0.6
+pkgver=0.7
pkgrel=1
pkgdesc="A scripting language for interactive music"
arch=('i686' 'x86_64')
@@ -13,8 +13,8 @@ provides=("bipscript")
conflicts=("bipscript")
source=("https://github.com/bipscript/$pkgname/archive/v$pkgver.tar.gz"
"$pkgname-v$pkgver.patch")
-md5sums=('085193d085486b9b641ea52ca8e8230e'
- 'c775c269b2b654289b93e34858a85699')
+md5sums=('ccbf7ce80d8ef19c55d15b226d7b8cef'
+ '38886856c32d00d420bdf07e7469cfd5')
prepare() {
cd "$pkgname-$pkgver"
@@ -23,7 +23,7 @@ prepare() {
build() {
cd "$pkgname-$pkgver"
- cmake -DCMAKE_INSTALL_PREFIX=/usr .
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DBIPSCRIPT_VERSION=v$pkgver .
make
}
diff --git a/README b/README
index 25492c3e3ab2..6eb2ee3fc4f7 100644
--- a/README
+++ b/README
@@ -1,4 +1,9 @@
+commands to update system:
+
+sudo pacman -Syy
+sudo pacman -Su
+
command for chroot build:
extra-x86_64-build
diff --git a/bipscript-v0.7.patch b/bipscript-v0.7.patch
new file mode 100644
index 000000000000..ae77282ae1f3
--- /dev/null
+++ b/bipscript-v0.7.patch
@@ -0,0 +1,24 @@
+--- ./src/bipscript-0.7/src/midifile.cpp 2018-12-11 08:50:57.000000000 -0800
++++ ../bipscript/src/midifile.cpp 2019-02-02 16:46:39.819996298 -0800
+@@ -2,7 +2,7 @@
+ #include <cstring>
+ #include <iostream>
+ #include <fstream>
+-#include <portSMF/allegro.h>
++#include <portsmf/allegro.h>
+
+ namespace bipscript {
+ namespace midi {
+--- ./src/bipscript-0.7/CMakeLists.txt 2019-04-24 14:43:21.803333329 -0700
++++ ../bipscript/CMakeLists.txt 2019-04-22 16:55:17.000000000 -0700
+@@ -10,8 +10,8 @@
+ set(VERSION_COMMAND "git")
+ set(VERSION_ARG "describe")
+ else()
+- set(VERSION_COMMAND "cat")
+- set(VERSION_ARG "version")
++ set(VERSION_COMMAND "echo")
++ set(VERSION_ARG "${BIPSCRIPT_VERSION}")
+ endif()
+ message(STATUS "create version.h from ${VERSION_COMMAND} ${VERSION_ARG}")
+ execute_process(COMMAND ${VERSION_COMMAND} ${VERSION_ARG}