summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD54
-rw-r--r--bisq.desktop9
-rw-r--r--bisq.sh2
-rw-r--r--bitsquare.desktop9
-rw-r--r--bitsquare.sh2
6 files changed, 62 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7477c4ab4f6e..73aed7a31cfd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,28 @@
# Generated by mksrcinfo v8
-# Mon May 22 15:22:10 UTC 2017
-pkgbase = bitsquare
+# Wed Jul 5 14:41:05 UTC 2017
+pkgbase = bisq
pkgdesc = Cross-platform desktop application that allows users to trade national currency (dollars, euros, etc) for bitcoin without relying on centralized exchanges
- pkgver = 0.4.9.9.3
+ pkgver = 0.5.1
pkgrel = 1
url = https://bitsquare.io/
arch = any
license = AGPL3
makedepends = maven
makedepends = jdk8-openjdk
+ makedepends = protobuf
depends = java-openjfx
- source = bitsquare::git+https://github.com/bitsquare/bitsquare.git#tag=v0.4.9.9.3
- source = git+https://github.com/bitsquare/bitcoinj.git#commit=3a2e6baae74e4ed8d20edf73a2914297cde47f6c
- source = bitsquare.sh
- source = bitsquare.desktop
+ source = bisq::git+https://github.com/bitsquare/bitsquare.git#tag=v0.5.1
+ source = git+https://github.com/bitsquare/bitcoinj.git#commit=c7aee7e0d91ca3d84281156ee2b2b9fddc3a8d56
+ source = git+https://github.com/bitsquare/libdohj.git#commit=b88940e29cbae01619fbd091df92935b326d94e7
+ source = git+https://github.com/bitsquare/btcd-cli4j.git#commit=9d7ff85ab450b96c890e569dc9b584eae7bf13ad
+ source = bisq.sh
+ source = bisq.desktop
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = 95a61502d44523c983549d6bf3deb81dc49fef490a187d28fd16e024c2d3e2aa
- sha256sums = 15592a05a2a4d6cb65c757e9eec5e3818bf38e7397a3b98e7651a8a3b51f9ba9
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = 175e18841dd216ca84391a89b0fba0b12bf575ec095d200ae9a3babc83693e31
+ sha256sums = 2f9da2f32bb7d023af78bcbf688bc8dc01f24e1d6c7e3227928e22338343587c
-pkgname = bitsquare
+pkgname = bisq
diff --git a/PKGBUILD b/PKGBUILD
index 03357d2c8e2b..10d58d50a8ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,48 +1,66 @@
# Maintainer: David Parrish <daveparrish@tutanota.com>
-pkgname=bitsquare
-pkgver=0.4.9.9.3
+pkgname=bisq
+pkgver=0.5.1
pkgrel=1
pkgdesc="Cross-platform desktop application that allows users to trade national currency (dollars, euros, etc) for bitcoin without relying on centralized exchanges"
arch=('any')
url="https://bitsquare.io/"
license=('AGPL3')
depends=('java-openjfx')
-makedepends=('maven' 'jdk8-openjdk')
+makedepends=('maven' 'jdk8-openjdk' 'protobuf')
source=("${pkgname}::git+https://github.com/bitsquare/bitsquare.git#tag=v${pkgver}"
- "git+https://github.com/bitsquare/bitcoinj.git#commit=3a2e6baae74e4ed8d20edf73a2914297cde47f6c"
- "bitsquare.sh"
- "bitsquare.desktop")
+ "git+https://github.com/bitsquare/bitcoinj.git#commit=c7aee7e0d91ca3d84281156ee2b2b9fddc3a8d56"
+ "git+https://github.com/bitsquare/libdohj.git#commit=b88940e29cbae01619fbd091df92935b326d94e7"
+ "git+https://github.com/bitsquare/btcd-cli4j.git#commit=9d7ff85ab450b96c890e569dc9b584eae7bf13ad"
+ "bisq.sh"
+ "bisq.desktop")
sha256sums=('SKIP'
'SKIP'
- '95a61502d44523c983549d6bf3deb81dc49fef490a187d28fd16e024c2d3e2aa'
- '15592a05a2a4d6cb65c757e9eec5e3818bf38e7397a3b98e7651a8a3b51f9ba9')
+ 'SKIP'
+ 'SKIP'
+ '175e18841dd216ca84391a89b0fba0b12bf575ec095d200ae9a3babc83693e31'
+ '2f9da2f32bb7d023af78bcbf688bc8dc01f24e1d6c7e3227928e22338343587c')
+
+prepare() {
+ msg 'Fixing protoc path...'
+ sed -i 's#/usr/local/bin/protoc#/usr/bin/protoc#g' "$pkgname/common/pom.xml"
+}
build() {
# Use a temporary local maven repository.
local mvn_repo="$srcdir/mvn-repository"
- cd "${srcdir}/bitcoinj"
- echo "Building bitcoinj ..."
+ cd "${srcdir}/bitcoinj" || exit
+ msg2 "Building bitcoinj ..."
mvn clean install -Dmaven.repo.local="$mvn_repo" -DskipTests -Dmaven.javadoc.skip=true
- cd "${srcdir}/${pkgname}"
- echo "Building bitsquare ..."
+ cd "${srcdir}/libdohj" || exit
+ msg2 "Building libdohj..."
+ mvn clean install -Dmaven.repo.local="$mvn_repo" -DskipTests -Dmaven.javadoc.skip=true
+
+ cd "${srcdir}/btcd-cli4j" || exit
+ msg2 "Building btcd-cli4j..."
+ mvn clean install -Dmaven.repo.local="$mvn_repo" -DskipTests -Dmaven.javadoc.skip=true
+
+ cd "${srcdir}/${pkgname}" || exit
+ msg2 "Building bisq..."
mvn clean package -Dmaven.repo.local="$mvn_repo" -DskipTests
+
}
package() {
# Install executable.
- install -D -m755 "bitsquare.sh" "${pkgdir}/usr/bin/bitsquare"
- install -D -m644 "${srcdir}/${pkgname}/gui/target/shaded.jar" "${pkgdir}/usr/share/java/bitsquare/shaded.jar"
+ install -D -m755 "bisq.sh" "${pkgdir}/usr/bin/bisq"
+ install -D -m644 "${srcdir}/${pkgname}/gui/target/shaded.jar" "${pkgdir}/usr/share/java/bisq/shaded.jar"
# Install desktop launcher.
- install -Dm644 bitsquare.desktop "${pkgdir}/usr/share/applications/bitsquare.desktop"
- install -Dm644 "${srcdir}/${pkgname}/package/linux/icon.png" "${pkgdir}/usr/share/pixmaps/bitsquare.png"
+ install -Dm644 bisq.desktop "${pkgdir}/usr/share/applications/bisq.desktop"
+ install -Dm644 "${srcdir}/${pkgname}/package/linux/icon.png" "${pkgdir}/usr/share/pixmaps/bisq.png"
# Install BouncyCastleProvider
# https://github.com/bitsquare/bitsquare/blob/master/doc/build.md#3-copy-the-bountycastle-provider-jar-file
local mvn_repo="$srcdir/mvn-repository"
- install -Dm644 "$mvn_repo/org/bouncycastle/bcprov-jdk15on/1.53/bcprov-jdk15on-1.53.jar" \
- "${pkgdir}/usr/lib/jvm/java-8-openjdk/jre/lib/ext/bcprov-jdk15on-1.53.jar"
+ install -Dm644 "$mvn_repo/org/bouncycastle/bcprov-jdk15on/1.56/bcprov-jdk15on-1.56.jar" \
+ "${pkgdir}/usr/lib/jvm/java-8-openjdk/jre/lib/ext/bcprov-jdk15on-1.56.jar"
}
diff --git a/bisq.desktop b/bisq.desktop
new file mode 100644
index 000000000000..def04818c680
--- /dev/null
+++ b/bisq.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Bisq
+GenericName=P2P Bitcoin Exchange
+Comment=Bisq is a cross-platform desktop application that allows users to trade national currency (dollars, euros, etc) for bitcoin without relying on centralized exchanges
+Exec=/usr/bin/bisq
+Icon=/usr/share/pixmaps/bisq.png
+Terminal=false
+Type=Application
+Categories=Utility;Finance;
diff --git a/bisq.sh b/bisq.sh
new file mode 100644
index 000000000000..424d67d6de27
--- /dev/null
+++ b/bisq.sh
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec "$JAVA_HOME/bin/java" -Dsecurity.provider.11=org.bouncycastle.jce.provider.BouncyCastleProvider -jar /usr/share/java/bisq/shaded.jar "$@"
diff --git a/bitsquare.desktop b/bitsquare.desktop
deleted file mode 100644
index d1bfc57c419f..000000000000
--- a/bitsquare.desktop
+++ /dev/null
@@ -1,9 +0,0 @@
-[Desktop Entry]
-Name=Bitsquare
-GenericName=P2P Bitcoin Exchange
-Comment=Bitsquare is a cross-platform desktop application that allows users to trade national currency (dollars, euros, etc) for bitcoin without relying on centralized exchanges
-Exec=/usr/bin/bitsquare
-Icon=/usr/share/pixmaps/bitsquare.png
-Terminal=false
-Type=Application
-Categories=Utility;Finance;
diff --git a/bitsquare.sh b/bitsquare.sh
deleted file mode 100644
index d70a945e166e..000000000000
--- a/bitsquare.sh
+++ /dev/null
@@ -1,2 +0,0 @@
-#!/bin/sh
-exec "$JAVA_HOME/bin/java" -Dsecurity.provider.11=org.bouncycastle.jce.provider.BouncyCastleProvider -jar /usr/share/java/bitsquare/shaded.jar "$@"