summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD38
-rw-r--r--bitchat.desktop8
-rw-r--r--bitchat.sh3
4 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c61e553b8ecb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = bitchat
+ pkgdesc = Secure, peer-to-peer instant messenger
+ pkgver = 4.6.3
+ pkgrel = 1
+ url = https://bitchat.im/
+ arch = any
+ license = GPL3
+ makedepends = imagemagick
+ makedepends = git
+ depends = mono
+ source = git+https://github.com/TechnitiumSoftware/BitChatClient#commit=50d2c949b598e1abaa5088442055f4962f7f0b53
+ source = bitchat.sh
+ source = bitchat.desktop
+ sha256sums = SKIP
+ sha256sums = a630f23eb2b9044a1ceab3b2a0db6f18544710e60fa874ff6025eb45aa6795c3
+ sha256sums = 406048fc6b7540c9d23a9ef01685821a4fc437c7b0ed1a9b0cd4be8444c426c2
+
+pkgname = bitchat
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d267974ba308
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# $Id$
+# Contributor: Balló György <ballogyor+arch at gmail dot com>
+
+pkgname=bitchat
+pkgver=4.6.3
+pkgrel=1
+pkgdesc="Secure, peer-to-peer instant messenger"
+arch=(any)
+url="https://bitchat.im/"
+license=(GPL3)
+depends=(mono)
+makedepends=(imagemagick git)
+_commit=50d2c949b598e1abaa5088442055f4962f7f0b53
+source=("git+https://github.com/TechnitiumSoftware/BitChatClient#commit=$_commit"
+ "$pkgname.sh"
+ "$pkgname.desktop")
+sha256sums=('SKIP'
+ 'a630f23eb2b9044a1ceab3b2a0db6f18544710e60fa874ff6025eb45aa6795c3'
+ '406048fc6b7540c9d23a9ef01685821a4fc437c7b0ed1a9b0cd4be8444c426c2')
+
+prepare() {
+ cd BitChatClient
+ sed -i '/SocketOptionName.IPv6Only/d' BitChatCore/Network/{LocalPeerDiscovery.cs,Connections/ConnectionManager.cs}
+}
+
+build() {
+ cd BitChatClient
+ xbuild /p:Configuration=Release BitChatClient.sln
+ convert BitChatAppMono/logo2.ico[2] ../$pkgname.png
+}
+
+package() {
+ cd BitChatClient
+ install -Dm644 -t "$pkgdir/usr/lib/bitchat" BitChatAppMono/bin/Release/*
+ install -Dm755 ../$pkgname.sh "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 ../$pkgname.png "$pkgdir/usr/share/pixmaps/$pkgname.png"
+ install -Dm644 ../$pkgname.desktop "$pkgdir/usr/share/applications/$pkgname.desktop"
+}
diff --git a/bitchat.desktop b/bitchat.desktop
new file mode 100644
index 000000000000..c11a0a27b273
--- /dev/null
+++ b/bitchat.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=Bit Chat
+Comment=Secure, peer-to-peer instant messenger
+Exec=bitchat
+Icon=bitchat
+Categories=Network;InstantMessaging;
diff --git a/bitchat.sh b/bitchat.sh
new file mode 100644
index 000000000000..104fb68ea7a2
--- /dev/null
+++ b/bitchat.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+mono /usr/lib/bitchat/BitChat.exe